Sunset rule triggering early

Hi all,

Just had a quick question on something I'm seeing. I have an enbrighten z-wave dimmer switch being controlled by a basic rule to turn on at Sunset but it seems to be triggered earlier everytime. My time is correct in hub details and sunrise is looking to be working properly.

Providing all the details below. Let me know your thoughts and if there is any other items that would be helpful.

Thank you

Is your latitude/longitude set correctly?

I'm using my zip code. The sunset time listed as sunset is correct. I just double checked lat/long and it is correct. Verified it against a search online as well.

As you can see pending action is earlier than current sunset variable of 8:31 pm.

Have you hit โ€œDoneโ€? That should cause rescheduling.

Yes, I hit done twice so it goes back to the app screen. It's been running for awhile now. I used to have it running earlier at a lower setting so I'm wondering if that is somehow stuck. Rebooted and everything.

I was just looking at the variables and noticed the sun offset is 40 min. That matches the amount of time it's going off early. Can I clear that variable or so I need to recreate the rule because I don't have an offset in the rule currently.

Atsunsetoffset is equal to - 40. Seems that's the problem.

Anyone know how to clear this variable or is the only method to recreate the rule?

First, let me say that Iโ€™m not a Basic Rules user. That said, I fired up an instance and I can confirm what you seem to be seeing. I also found a workaround.

Repeat by:

Define Basic Rule, hit Done.

You will see a job scheduled 40 minutes after sunset, and the settings page is as expected, similar to yours.

Now, go into the Basic Rule, change the action to occur at sunset. Hit Done. Hitting Done is critical, should cause rescheduling.

However, the settings and the doActions scheduled run are still for 40 minutes after sunset.


Go back to defining when the rule is to occur, change it to time after sunset, replace the 40 (still left from above) to 0. Hit Done.

Seems to be a bug.

Tagging @bravenel

That did the trick! Thank you.

1 Like

I will look into it. Your work-around pretty clearly points out the bug, i.e., not clearing out the setting for offset, and later using it.

1 Like