Suddenly, All GE Link Bulbs Not Responding


I've had hubitat working with my ~25 ish GE Link bulbs for about a month. Not perfectly (eg, when I turn a group off, many times it takes repeated off presses to get all the lights in the group to respond).

I also have peanut plugs throughout the house.

But yesterday they ALL stopped responding at the same time. My 1 sengled bulb is still responding. I know the typical answer is move off the GE Link Bulbs, but I figure there's something going on that may be a simple fix.

I've tired the following:

  • turning router off and on
  • turning the hub off and on
  • disabling zigbee and re-enabling
  • changing the zigbee channel - it was at 20, tried 19, then tried 25, now back to 20
  • going in to one light and pressing 'configure' (no idea what that does but I did it)
  • going in to the same light and pressing refresh (no idea what that does either)
  • going in to the same light and changing it from generic zigbee bulb to dimmer, no effect, then changed back to bulb, no effect
  • yelling at the entire system, no effect
  • coincidentally, I reset and set up for the first time on the hub one light after this happened, and that one is responsive

Any thing else I can do other than resetting each bulb?

Thanks in advance!

Editing to add:
I just checked and the peanut plugs aren't showing up in my device list on Hubitat.

Also, my three Schlage door locks disappeared roughly ~ 3 hours after I got them online. Probably unrelated, but now seeing that the plugs also disappeared, wondering if it is related. The locks disappeared about a week ago - no idea when the plugs disappeared as I don't actually use them, I just added them to have them as repeaters (as I had read about that on this community forum).

I have to think you are dealing with database corruption. I have never had any device just disappear that I hadn't deleted, so that's new. You might want to perform a soft reset and of course, the GE bulbs are bad repeaters from what I've read on here, I have no experience with them, but I have had issues with the Peanuts. I just updated the firmware on the Peanut plugs with this method and they seem to be working better after the update. Before you do anything, tagging support @bobbyD to see what he thinks your first step should be.


I'm going to echo what @Ken_Fraleigh said. You should definitely contact

This comment concerns me the most vis-a-vis database corruption. How did you turn your Hubitat off and back on?

Ken - I'll wait to hear more on this from Bobby before I do anything.

But what will I lose with a soft reset?

1 Like


I did a few reboots via the menu option in the hubitat app, to no avail.

Last night I tried unplugging and replugging, no change in any behavior - the lights that weren't working before still aren't, the ones that were (the 1 Sengeld, and the one GE Link that I set up after this problem started), are still working.

Also apologies to all - I'm not used to this type of forum, no idea how to multiquote, or quote at all it seems! Feeling old now :slight_smile:

1 Like

It can take some time for zigbee devices to “find” the new channel (like over 24 hours, for some battery devices at least), so it’s possible multiple channel changes in a short period of time is also contributing to the confusion.

Edit: I really don’t know if this is related, it’s just a thought. :slightly_smiling_face:

Figured out the quoting! To be clear about the channels, this was after a day of all the lights not responding.

While the reboots didn't help, this approach is less likely to cause issues.

This is not recommended.

Understood, I’m sure it’s not the only problem.

Just FYI, zigbee channel changes can confuse end devices until they have reconnected to the hub (which doesn’t occur immediately).

Also the higher channels (like 25) seem to be difficult/impossible for some zigbee devices to connect to, based on what some people report here (and I have also found to be true).

You don't lose anything with a soft reset as long as you have downloaded a backup of the hub (to a computer) prior to doing it. Once the soft reset has finished, you are given the option on screen to restore from backup. The beauty of this is that it fixes the database corruption in the process, while restoring everything else (rules, location, modes, etc.). FYI, a database corruption can be caused by abruptly pulling the power to the hub.
EDIT: Also, you can reset the GE bulbs without removing them from the hub. Once reset, you can run a Zigbee discovery and the hub will join them back with their appropriate names and rules (if you created automations with them). The beauty of Zigbee vs Z-wave. This doesn't explain what happened to make them lose connection to the hub in the first place.

1 Like