Strange issue with V1 iris smart button and V1 control switch

I just installed a V1 Iris smart button and set it to turn on and off a light plugged into a Iris V1 control switch with a Rule. I tried setting 1 rule to turn the light on and another to turn it off. However, no matter what settings I use whenever the light is turned on it blinks 2 times before it stays on. Pressing the button again to turn the light off is not a problem. I deleted both rules and remade them, and I also tried rebooting the hub to no avail. I tried unplugging the control switch, and I also tried amending the rule so that instead of having two rules (one to turn the light on and another to turn it off) I instead set the rule to toggle the switch on and off. None of this has worked. Every time the light gets turned on, it continues to blink 2 times before it stays on. Can anybody guess what I am doing wrong, or what I can do to resolve this issue? Currently running 2.3.4.120. Thank you all!

UPDATE: I removed the button and reinstalled it and created a new rule to toggle the control switch on and off again. Same issue persists: light turns off normally but upon turning it on it blinks twice before it stays on. I'm at a loss what I'm doing wrong...

UPDATE 2: the issue is now also affecting turning the light on and off via the dashboard (meaning without using the rule and the smart button). Before I tried installing the smart button, I could turn the light on and off via the dashboard without this blinking behavior happening.

UPDATE 3: trying to find the issue by process of elimination, I removed the control switch, deleted it form the rules that were associated with it, and then repair it and readded it to the rules. Issue still persists despite reinstalling the control switch. Baffling.

can you try turning on/off another device, ie: don't use the lightbulb, use a fan or something

1 Like

Thank you for your suggestion. I plugged in a fan, and then turned the control switch on and off via the dashboard and the smart button and it functioned normally. It seems the issue is only present when controlling the light for some reason. BTW, I forgot to mention that when I first installed the smart button, it did work properly the first few times. The issue only appeared when I tried installing a rule that would toggle the control switch on and off, and persists despite deleting the rule, rebooting the hub, and all the other stuff I mentioned in my previous updates...do you think the issue is being caused by the bulb itself? UPDATE: I just plugged the offending light directly into the outlet and tried turning it on and off with its own switch...it blinked twice before staying on. Somehow, after using the smart button something happened to the bulb that made it display this behavior (maybe some unexpected voltage variance?). Now the issue is how to prevent the issue from happening to another bulb so that I can use the smart button and the control switch as I need to use them.

UPDATE: it was the bulb. I replaced it with a standard LED bulb and both the smart button and the control switch work properly. The bulb that was damaged was an OSRAM LIGHTIFY LED bulb that was being used as a standard bulb (it was not connected or controlled by anything else other than the control switch and then the smart button). Somehow something was damaged in the internals when I used the smart button that bricked it into blinking twice every time it gets turned on. At least with this brand, one should not use a connected bulb with a control switch / smart button to prevent damaging the bulb. Thank you for helping me figure this out!

1 Like

Yeah, with smart bulbs they are meant to have power 24/7 and only be controlled via zigbee. Whta's the bulb model #?

1 Like

Model 73893, Osram Lightify LED connected bulb. Strangely, I did use it exclusively with the control switch without any issues whatsoever (even had it on a schedule turning on and off every day for months) until I introduced the smart button into the mix.

I think the flashing means the bulb is ready to be paired. I had some of those bulbs years ago and they caused a lot of problems with my ST system. I probably still have them in a box somewhere.

2 Likes

Thank you thank you thank you for pointing this out! I had actually discarded the bulb thinking its electronics had been damaged. It had in fact been accidentally reset into pairing mode when I was testing the control switch and smart button (if you turn the bulb on and off three times it goes into pairing mode, DUH!). I just retrieved it and successfully paired it using a "generic zigbee bulb" driver and it works perfectly. What a great community.

2 Likes

Download the Hubitat app