Strange group light behavior

I have 2 groups (one with 3 Sengled bulbs and one with 2 Cree bulbs). Lately, one bulb in each group (it's always the same bulb) sometimes does not turn on with my SL automation. I can turn the Sengled bulb on by itself but the Cree bulb needs to be turned off from the switch. All bulbs turn off with the SL rules (and the SL rules use the groups to turn the bulbs off). I do have Zigbee messaging turned on for both groups and the rules run at different times.

The misbehaving Sengled bulb also turns on in the morning and that has been working flawlessly. Any idea as to what may be going on?

It's almost alwasy a mesh issue. Cree in general can be persnickety...


Yeah - I've had a repeater in place that seemed to alleviate the issue but it's started happening again recently. The odd thing is that of the 3 Sengled bulbs, the one that is misbehaving is not the furthest one (it's in the middle of the group of 3 in distance from the hub/repeater).

I will eventually replace the Cree bulbs with Sengled (I've been told that Segneld are more Hubitat "friendly" :grinning:)

Do you have "Enable on/off optimization" on or off?

I've had a few issues with the Sengled Bulbs (not color changing) and groups also. This is what seems to be happening. Turning off the on/off optimization seems to help if you are using the Sengled Element Classic driver. If you are using the Generic Zigbee Bulb Driver instead of the Sengled Element Classic driver you can leave the on/off optimization on. I prefer the Generic Driver because it comes on instantly instead of fading up to whatever level it is set for.

The on/off optimization merely checks the on/off state of the devices and doesn’t send “on” commands to devices reporting “on” and vice versa. Make sure the bulb is reporting correctly in the device page. Also, when changing drivers you have to hit “configure “ for the new driver to function properly.
Otherwise it’s probably just routing through a cree light and the cree is dropping the commands.

Currently, I have optimization turned off.

I recently switched to the Sengled drivers. I should probably switch back and see if it helps.

Yep - have done that when I switched from generic to the Sengled drivers

I was using the group to turn on/off. The other two would work correctly. The Cree bulbs are upstairs while these 3 are downstairs about 5 feet from each other. I wish there was an easy way to map the network, but if it goes by physical proximity, it would be unlikely that Cree is in the mix :crossed_fingers:t3:

It doesn’t. You can check the routing table http://hubsIPaddress/hub/zigbee/getChildAndRouteInfo and see if the light in question is listed and what it’s routing through. Also; what is the repeater you added?


I never knew this!! Live and learn - thanks! The "upstairs" bulbs are the Cree bulbs and the "Upstairs Filing Cabinet" one is the problematic one. The routing table seems to be missing the 3 downstairs Sengled completely (Doorway Mirror, Living Room1 and Living Room2).

"Routing Table

Parent child parameters
EzspGetParentChildParametersResponse [childCount=0, parentEui64=0000000000000000, parentNodeId=65535]

Child Data

Neighbor Table Entry
[Upstairs Desk Lamp, 023F], LQI:254, age:3, inCost:1, outCost:3
[Upstairs Filing Cabinet, 75E5], LQI:252, age:4, inCost:3, outCost:3
[Inside Zigbee Extender, ADC6], LQI:252, age:4, inCost:3, outCost:5
[Fireplace Lamp, BD62], LQI:249, age:3, inCost:3, outCost:3

Route Table Entry
status:Active, age:64, routeRecordState:0, concentratorType:None, [Inside Zigbee Extender, ADC6] via [Inside Zigbee Extender, ADC6]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Upstairs Desk Lamp, 023F] via [Upstairs Desk Lamp, 023F]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Bedroom Lamp, 39A7] via [Inside Zigbee Extender, ADC6]
status:Active, age:64, routeRecordState:0, concentratorType:None, [Upstairs Filing Cabinet, 75E5] via [Upstairs Filing Cabinet, 75E5]

Could this be because I just changed the drivers to Generic Zigbee Dimmer?

PS: The repeater is Centralite Smart Plug Mini (Works with SmartThings, Wink, Hubitat, Vera Plus, Echo Plus, Home Assistant, and ZigBee platforms)

1 Like

It's not doing well. You want to make sure that your extenders are fairly close to the hub, or about midway between the hub and device at most. I believe, but someone can correct me, the Sengled's routing path is more than one hop from the hub, and the table only shows the last hop.

I'm pretty sure that Incost and outcost are error rates with 1 being the best and 5 the worst. I've seen others complain that these are weak repeaters.


The routing table is a good tool but it needs some time to get all of the routing data filled in. If you reboot the hub it will be almost blank for awhile. I have it set as a bookmark in chrome. Don't let it drive you crazy. The best way to get reliable zigbee is to add powered repeaters. When your mesh is good you won't have any reason to look at the routing table. My favorite repeater based on the routing table is a Samsung Outlet. The Ikea Tradfri outlets are very afordable and also work well but will only route about 5 items.

1 Like

Thanks @nibyak @Ken_Fraleigh. I'll see how things behave over the next couple of days.

I rebooted the hub a couple of days ago after an update. Does it take that long?

You might want to try and shut the hub off for 20 minutes and let the Zigbee devices go into panic mode. When the hub reboots, they will supposedly find the best route back to the hub.

I am probably just wrongly assuming things, but I don't like it when devices in the table route back to themselves and nothing else. I would like to see them going through other devices.

I do something drastic when I want to fill the route table, I go through every Zigbee device and hit the refresh button in the device page. That seems to wake the device, and if I am quick enough I can have almost everything in the Zigbee mesh awake at one time. I am not saying you should do this, or that it is even necessary, or that it even works, but it does make the table fill up.

1 Like

I’ll second that. They will repeat for around 10 devices, which helps to justify the price.


At least you don’t look like a lunatic running around setting off motion sensors and opening and closing all the doors, and pushing buttons. Not that I’ve ever done that :shushing_face:


I would never admit to doing that either. Besides, I am too old and out of shape to do that too often. Much easier to push a button.


Do the devices need to be “on” when doing the refresh? I just tried it and there was no change.:frowning:

Shouldn't make a difference, but I do sometimes toggle them on and off when I am on that page.

And remember, the routing table page is static, you will have to refresh it to get the latest status.

1 Like

Quick update: Since switching back to the generic drivers, the lights have been coming on as they are supposed to (based on the last 2 days). The lights still don't show in the zigbee routing tables, but two zigbee buttons that previously were not there are now listed. Keeping my fingers crossed :crossed_fingers:t3: