Strange CT101 behavior-did not follow settings


#41

Update: I ended up having to do a factory reset. I am still going through re-pairing the devices I had connected before. I did the thermostat first. Both last night and this morning, it changed settings according to schedule.

Of all the devices, the thermostat was the only one not properly behaving that I know of. The other Z-Wave devices (siren, glass break detector, smoke/CO detector) could have been also not functioning properly but since those don't give any indication, I wouldn't have known. The response to my trouble ticket was that the Hubitat's database had become corrupted. I think this might have happened when a car took out a telephone pole near us and our power was out long enough that the UPS to which I had the Hubitat connected ran out of power so the Hubitat had a dirty shutdown. I tried a soft reset and restore from backup, but I suspect the backup was also corrupted. Thus, the factory reset and going through the process of re-pairing everything.

Once everything is connected again, I will be sure to make a backup and to label it this time so I won't delete it. I'll probably make a folder specifically to hold the backups so they won't be mixed in with other files. With this, I guess this issue can be marked as Solved.


#42

@mike.maxwell. I noticed my ct101 paired as generic zwave thermostat. I had to manually set it to the ct101 driver. Not sure if this intended or not.

If you'd like the fingerprint data let me know and bbn I'll repair it in a bit.


#43

yes please, no need to re-pair it, just copy/paste the info as text from the data section in the driver details


#44
  • deviceType: 25857
  • inClusters: 0x20,0x81,0x87,0x72,0x31,0x40,0x42,0x44,0x45,0x43,0x86,0x70,0x80,0x85,0x60
  • deviceId: 12
  • manufacturer: 152
  • lastRunningMode: cool

#45

Since doing the factory restore, things are back to operating properly. It has been a pain resetting and re-pairing all my devices that were connected to the hub, but having it operate properly again makes it the thing that isn't desirable to do but what had to be done.
Thanks for your help. I should have submitted the trouble ticket much earlier. I am going to have to get the Hubitats along with the cable modem and routers on a dedicated UPS that isn't shared with the computer.

If something should happen in the future, I will have some good backups saved.


#46

Apparently, this is not resolved with the factory reset. :frowning_face:

I came home and the thermostat's heating set point changed, but the cooling set point did not.

I had changed the driver from the Generic Z-Wave Thermostat to the Radio Thermostat CT101 driver. I am going to change it back since it had looked like it was behaving when it had that configuration.

Further edit: I noticed that the dashboard tile intermittently reflects the current state of the thermostat so I wr-did the thermostat refresh rule to refresh it every 30 seconds. Hopefully, that will work.

Edit: And again, the dashboard tile is not updated because the thermostat device in Hubitat is not following the state of the physical thermostat. It was idle but the driver and dashboard were indicating it was cooling.

Could there be a problem with the Z-Wave part of the radio dongle on my C4 hub?

Edit: I restored a database I had saved from when I got it set back up again. Even though I had not switched it back, the thermostat is on the CT101 driver and it did switch properly this morning. Hopefully, it will stay working properly this time.


#47

I created a rule again to refresh the thermostat every 30 seconds. Hopefully, that will be what was needed to make sure my dashboard tile is in sync with what the thermostat is doing. It seemed to be hit or miss as to whether the tile would update the status to reflect the operating state (cool or idle). Other than that, the Thermostat Manager's changes for Wake and Night periods seems to be working now. I'll know more in a few days after I have had a chance to observe it.


#48

After fighting with this for a very long time, I finally threw in the towel and went for the 5-carrot rated GoControl. No more thermostat refresh rule or spending hours trying to figure out why something that was being triggered by my thermostat (e.g. fans) didn't work etc.


#49

So far with the refresh, the thermostat is behaving quite well. Hopefully, it will continue to do so. Is the GoControl Zigbee or Z-Wave?


#50

It's Z-Wave.


#51

Thanks. If I have problems again, I will have to check it out. Please share your experience with it once you get it and have it working.


#52

I have it working and it's pretty easy to use. I put the batteries in it and then connected it to my hub. After that, I transferred all the rules over to it and then replaced the CT with it. I don't have the additional refresh rule running and I was able to calibrate it with my other temp monitors. Overall I'm very pleased with it and a bit pissed with myself for staying with the CT so long. The only reason I stuck it out was that I could adjust the CT by .5 degrees when calibrating it. After a long think it just wasn't worth it.


#53

So far, mine is working well after the factory reset of the hub and re-pairing all my devices that were connected to it. I did need to put the refresh rule in. I was looking online at the thermostat you got. If it were Z-Wave Plus, I might switch. OTOH, if I am going to spend the money, I think I will go for one of the Zigbee models I saw if I can find one on the compatible devices list or if I find one that others have gotten working with Hubitat. I don't want to be the pioneer and purchase one that won't work.


#54

I decided to change thermostats to a Zigbee model. I found a new Zen Zigbee Edition thermostat on eBay that with tax, delivery, and a 2 year Square Trade warranty, comes in at less than $90. I would have liked to go with the new Lux KONOx, but the additional $60 that would have run was more than I wanted to spend.

In any case, when the Zen arrives and is installed, I will no longer have the CT101 Z-Wave issue. The only down side is that I will lose the Z-Wave repeater function. However, I only have three other Z-Wave devices (Smoke/CO detector, Siren, and Glass Break Detector), and none of those is at any significant distance from the hub so the loss of the repeater shouldn't be an issue.

I don't think it was a hardware issue with the thermostat. It seemed to be a communications issue because with the refresh rule, the thermostat has been functioning well and the temperature set points and status have been changing according to my settings. However, since most of my devices are Zigbee, I think the Zigbee thermostat will fit in better. The CT101 was migrated from Iris. Anyone want a used CT101 Radio Thermostat?


#55

I'll toss mine into the community pool as well!


#56

The Zen Zigbee Edition thermostat arrived today. It connected easily once I got the hardware installed. The installation instructions in the box were sparse. Instead, one is to go to the web site and the site guides one though the proper wiring connections and basic connection and testing. In all, it was pretty simple.

The thermostat is functioning well and the dashboard tile (removed the CT101 tile and added the Zen tile) is reflecting the status properly. It won't be until tomorrow that I will be able to see if the schedule is working properly, but I have confidence that it will function without issue. Now to find the box for the CT101.


#57

@mike.maxwell I've been having some trouble with hub lockups. After disabling user code Bobby said he is seeing the following error in the logs.

ERROR dev|3618|House air|groovy.lang.MissingMethodException: No signature of method: rtcCT101.pollDevice() is applicable for argument types: () values: []
Possible solutions: collect() (pollDevice)

I do not have any polling setup..

Any ideas what may be causing it?


#58

yeah, pollDevice is a scheduled job that the generic zwave thermostat sets up, the ct101 driver doesn't use nor have this method, hence the error

removing and pairing the device again will fix this, or you can wait for 2.1.1 where the updated driver will remove it on its own.


#59

Thank you sir.

Just found it odd support was pointing me at errors from the stock drivers.