Static IP Issues - When will it be fixed?

I've been setting up VLANs to improve security (Guests, IOT, Media, Biz, etc.). When I've tried to move my three HEs into the IOT VLAN and assign each a static IP there, they're just not sticking, and sometimes the HE just seems to disappear until I reset it, even though the light goes green (doesn't show up at all in the router client list, and no old or new IP addresses work to reach it until I reset). I have been able to get the new address to "take" for a day or so in two of the HEs, but then it reverts back even though it's on a UPS and has not had a power cycle. Really, really weird... I found a thread from earlier this year (Jan 26) that seems to indicate a known issue with static IPs, so I wondered if this will be addressed in a future release, please? I'm on the most current firmware version with all three of my C7's, so its not fixed yet.

I've triple checked the instructions and can confirm I've followed them closely (and tried to improve a few variations) but my needed static IPs remain elusive. I've even assigned a router access port to just the desired VLAN and tried working only on that to obtain a DHCP address on the correct subnet, and then change the IP address to static (with a subsequent reboot) while plugged into that port, but when I move the HE to its permanent location (plugged into a Trunk port on a switch), it loses the static IP address. Thanks.

1 Like

i have two different ups on two differnt routers. working fine.. my guess is something with your router.

1 Like

if you're plugging into a trunk port, it'll default to the untagged VLAN. you need to update your switch port to the correct VLAN to be untagged. this sounds more like a configuration issue, and not an HE issue

1 Like

Hmmm... What would be the behavior of wifi devices on the VLAN? They're all retaining their assigned VLAN static IPs. Only the Hubitat devices are having an issue. May well be my lack of good networking/VLAN/tagging knowledge, but all other devices seem fine. Will investigate more over the weekend. Thanks.

The wifi devices would only be affected by the wifi config within the vlan (consider the wifi itself as a port for your wifi devices) So unless the hard wired port(s) are configured the same way as @dadarkgtprince suggests you can run into this problem.

Well, I think this is exactly what's happening, then. I have a busy weekend of other work around the property, but will try to take some time to reconfigure things and correct this. Will report back.

I'm having a similar issue on my network. If I am connected to the FiOS's switch, I can assign a static IP address to the Hubitat and it works as expected.

The wrinkle, however, is the only thing that's connected to my FiOS's built-in switch is my router, which has a separate, internal network.

I cannot get the Hubitat to actually use any static IP other than the network my FiOS.

So, to recap, on, I can assign a static IP of no problem, but this is not where I want the Hubitat to live.

On my internal network,, the router is never available at the 192.168.168 address I assign it, instead it always reverts back to the IP I assigned it (or DHCP if that's off) and never seems to take the IP.

This is very frustrating as I was hoping to jump ship from SmartThings and all their connectivity issues (not counting you can't back up your settings), but I guess this ain't the solution, either, right now.

DHCP completly doesn't work, even with a static reservation internally or no reservation, so something's really wonky with Hubitat's networking.

So when you go to settings>>networking and set it for static with the 192.168.168.x it reverts back or are you trying to set it from dhcp?

I'm also not clear why you have the fios unit nat'd as one internal network and a separate router designated to another. Wouldn't it be easier to set the fios unit as passthrough, attach your router to the wan port of the fios unit and put everything behind the router?

Last time I checked, thatโ€™s not an option with the current generation fios router (G3100).

The Hubitat will not either take a DHCP address in or a static assignment.

Rationale for my network is the way it is aside, of the plethora of IoT devices I have, including, but not limited to:

  • Wemo
  • Ring
  • Nest
  • Tuya Smart
  • Alexa, and including the
  • Samsung SmartThings v3 hub,

the Hubitat is the outlier that will not play ball on this network. I think its suspect that, on the Hubitat static IP assignment page, you cannot enter anything other than a /24 (i.e. netmask, which to me, tells me that the Hubitat's networking code is kneecapped for some reason.

I seem to remember @gopher.ny saying there was a way to override that...

This post maybe?


Yeah, settings can be overridden by using the endpoint behind the app directly as @erktrek mentioned in the post above. The key parameter here is override=yes that bypasses some of the built in checks.


That's it... @robert.sink

Thanks for the info @rlithgow1, @erktrek, and @gopher.ny. I updated the URL to include my hub's present IP, which was reachable, and changed the network and netmask to be that of to match what I was trying to accomplish. I shut the hub down, unplugged it from power and network, plugging back into the desired network and giving power and no dice.

I really was hoping to switch off of SmartThings for a number of reasons, but primarily was that I've already been burned once by the hub dying and having to re-pair some 80 Z-Wave devices, but it seems I'll have to live with that danger a little longer.

That is weird especially since it's a /24 anyway.... Maybe @gopher.ny has some insights into why it's not staying.... There is no reservations anywhere in your dhcp table is there?

No, I just double checked. I did, originally start out months ago with a static DHCP reservation, but it is indeed disabled right now.

Use (without /24).

I did. This is exactly what I sent:

Did you reboot after using the endpoint? Also, do you get a blank webpage after sending that URL?