Static IP address Recovery Options - No Button, No Hard Reset

Using the default, I set up my new HE hub and connected a couple devices. Fine.

But, I have an existing setup in which my IP devices are in reserved space, so I tried to set up the static IP option. There was a problem during the restart, apparently, wouldn't connect. Bottom line, I tried a bunch of things to start over and finally re-assigned the router to set the address I wanted. I wanted to start fresh and saw the rec to perform factory reset with the button on the bottom. But no button! I found the round hole, but I can see straight into the the device to see a gold plated round contact, but no button. Can't reset that way.

I went into 192.168.1.15:8081 and saw "Soft Reset" and "Full Reset" options. I tried "Soft Reset" first. I was able to create a new profile with the new address, but now the system gives me a " Corrupt database found. Hub cannot continue." message. And the "Full Reset" option is gone now.

I'm dead in the water. Any ideas? I sent a note to support on the missing reset button, but waiting for response. I tried a different computer, hoping I could re-register with a completely different account, but it keeps finding the old hub name. How else to perform a factory reset?

1 Like

I suppose I'm not exactly sure what you're seeing, but on all of the hubs I looked at, the "network reset" button on the bottom of the hub does look gold, so it's possible you have the right thing. A blunt but relatively small object like the tip of a pen should be enough to press/hold it.

The button on the bottom is not a "factory reset," nor is that option available anymore, in no small part because it was often used for caes where it wasn't necessary, ths being one. :slight_smile: A soft reset would be more than enough to take care of this problem (a network reset, which is all that button does, would really be enough--if it does indeed work for you). Since you saw it there before, it's likely you were running an old hub version of the software and it got updated for you at some point.

My suggestions would be:

  • make sure you're using a good power supply for the hub (any 5V and 1A or greater power supply like the one included should work, but it can't hurt to try another)
  • try another soft reset -- it's odd you'd get an error about a corrupt databaes when it should be basically brand new, assuming you didn't choose to restore anything
  • since you already contacted support, see what they say when you hear back (I assume you used the new support.hubitat.com website instead of e-mail, but if not, I'd do that insted), and if you don't hear back ni a while, one of us can tag them here.

To switch your hub to a new account, you can either:

  • Log in to my.hubitat.com and use the "Deregister Hub" option (this is really the only thing a full reset would have done that a soft reset plus resetting both radios wouldn't have), then you'll be able to create a new account or choose a different one next time the hub is set up; or
  • Create the new account with the new e-mail address, if you haven't already, then, also from my.hubitat.com, find your hub, go to Hub Details, and use the Replace Admin feature--using the new account as one to replace the old one with.
2 Likes

https://docs.hubitat.com/index.php?title=Network_Setup#Static_IP.2FDHCP_configuration

This is how you return to DHCP.

3 Likes

Yeah, an image on the web showed what looked like a plastic insert, but I tried pressing and holding the gold button anyway, several times, and got no response. I feel no "give" and hear no click or anything. I tried pressing it for long periods of time... Maybe if it doesn't do anything, that would explain it....

Given that the power supply worked fine when I first set it up and it still seems to work properly when I power-cycle it (it goes through blue/green LED and the router sees it), I see no reason to try a different power supply.

I tried several soft resets. But I think I misunderstood the `new device' option at the bottom of the screen. It appears that option overwrites the "discovered" option that pops up. That seemed to let me create a new hub entry.

Thanks!

Aware of the "SmartHomePrimer" link, but that's not the issue. But thanks.

But this is the problem with "soft resets": there is no clear definition for what it does. Every company, and often individual products or product revisions, implement "soft reset" differently. Given this app tries to do everything (and does it poorly, as you noted), I tried to start small, so if I had to start over to match my network setup, I could easily wipe it clean and start over. Why make that hard to do?

Rather than taking away the "full reset" and including a static IP option that doesn't work, why not just say "Static IP assignment is disabled on this device. Use IP address reservations on your router instead."

"User interfaces" are for user convenience, not developer convenience.

I know you had some issues trying to use the static IP setting on the hub, but I haven't seen any info in this forum that it just doesn't work. So that generalization seems a bit of a bridge too far. :wink: No offense intended, but problems w/IP addresses (certainly including my own over the years) are frequently the result, at least in part, of user error. :slight_smile:

The full reset was removed because HE found that it caused more problems (and worse problems) for users than it resolved. Certainly one can argue the other side, that removing access is frustrating for users who know what they're doing and should be using it.

User interfaces are generally designed for the center of the normal curve, rather than the extremes on either end. :slight_smile: That can tend give users with the least and most ability some frustrating moments.

2 Likes

The full reset was wrongly used 99% of the time. People would have some minor problem, and go right to full nuclear mode. That wipes every piece of information from the hub and isn't recoverable. They would then complain that they wiped the hub and had to start over.

Soft reset on the other hand is less problematic. It clears the database, but does not clear the Zigbee and Zwave radios, so you can upload a copy of your saved database and things are back to normal. It is mostly useful for corruption, or to roll back in case you did something dumb (been there myself).

I wonder why your hub is missing that reset button. I would be curious to compare a picture of your reset to another hub. I suppose it is possible you didn't get a button soldered to the circuit board, but that would be a very rare if not almost impossible thing to get past quality control.

1 Like

It works for me. I have no idea why it hasn't worked in your use of it.

Agreed. But that generalization is always good cover for setup errors.

2 Likes

You're right; I'm not sure there is anywhere (outside of forum posts you can search for) where this was clearly defined. So, I've added a note first thing in the documentation for this feature:

https://docs.hubitat.com/index.php?title=Soft_Reset

The only reports I've seen of this "not working" have been when some part of the configuration was wrong--including times when things like 8.8.8.8 DNS (the default, I think) didn't work and the user just wasn't aware. Often times, your home router servers this function and can be specified manually instead.

If you want to do a DHCP reservation, that's my recommendation (much less to go wrong, usually) and you can just ignore this feature instead. :smiley:

As for full reset, I believe the issue is that staff observed it was happening more than it needed to. A soft reset takes care of most issues, including anything you've mentioned here, and there's nothing you could do with a full reset that you still can't do with a soft reset, manually resetting the radios (if needed), and un-registering from your account (if needed). That's all it would have done.

Still, I'm not sure if or why your hub might be missing the button, and I hope you get whatever network issues there may be figured out (regardless of where the issue is). If none of the above helps, hopefully you hear back from support after the workweek starts. Good luck!

2 Likes

That would be a singularly unique experience for anyone with a C-5 or C-7 model HE; does @user1235 have a C-3 or C-4 model Hubitat Elevation that was purchased on the secondary market?

1 Like

...and often the sequence of events which ends up being more consequential than one recognizes.

2 Likes

The picture featured in the "Network Setup" was taken in low light. I can confirm that the button is gold. Let me know if this is what you see on your hub:

For clarification purposes, pressing and holding this button for 10 seconds only resets the network settings. This button does not reset the hub.

We have reviewed your warranty claim and we do not think that you need a replacement at this time. Please let us know if you have any further questions or concerns.

2 Likes

Download the Hubitat app