Speak notification plays message PLUS old message

,

Hi everyone,

I’ve been having a problem for more than a year which I have neglected.

Now that I am really trying to fix it, just can’t do it.

On RM I use different rules where I use spoken messages, mainly on Sonos speakers, but I keep hearing the message I sent (woman voice), and most of the time I also get a second message I used months or years ago (man voice, which I used long time ago, I even erased that rule more than a year ago).

I have rewritten some rules from zero but can’t make that ghost message go away.

Is there a solution for this bug?

Look at your device page for your Sonos speaker(s). At the bottom look at the "in use by" section. Dollars to donuts you have multiple notification rules and don't realize it... (sometimes I get lost in the rules list and make a duplicate myself)

1 Like

@rlithgow1 Rick, I have double-checked this over and over.

As I mentioned, the problem I have is that I keep getting a ghost message, with a man’s voice I’m not using any more (I have configured a woman’s voice for months) since many months/years ago, and that doesn’t even exist anymore on any rule.

Hmmm that is indeed strange. I've only see that behavior with multiple notifications for the same device. Guess I owe you a donut. I'm gonna assume you have DHCP reservations for all your sonos speakers. What about re initializing the sonos integration on HE or factory resetting the sonos'?. Oh and where did you set the female voice? On the sonos' or in HE's Hub details page?

I found another post talking about this problem, and now I can’t find it to show it, but it mentioned something about an error of the Sonos app that caused a message to get stuck on the memory, and played it again and again.

So I checked for an update on that app and couldn’t find a newer one, and then I went over my Sonos devices (finally!!!) and discovered the message that repeated itself most of the time another message was played, hidden somewhere within the state variables.

And going through the options of the device, found one that I just toggled it to on, (Disable track data events), and after refreshing it and reloading it, the stuck message disappeared!

@rlithgow1 I appreciate the time you spent helping me solve this problem.

2 Likes

Nice, glad you got it solved!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.