Sonoff RF Motion Sensor migration from Smarthings to Hubitat

Hi All. I've been trying to migrate all my sensors from ST to Hubitat. I'm newbie to this platform, but I've been reading several posts. With the one that I've been struggling for the past 2 weeks, are with the Sonoff RF Bridge and the motion sensors.

I'm using @markus drivers and guide (Home · markus-li/Hubitat Wiki · GitHub), but have not been able to configure/add the children's motion & contact´s sensors into my devices. I flashed the Sonoff Bridge with both, Tasmota and Portisch.

Below you will find the log and the bridge configuration. Any suggestions or recommendations on the steps that I need to follow will be very much appreciated. Thanks!!

dev:842020-08-07 07:37:13.788 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:13.782 am info parseResult: [WebSend:Done]

dev:842020-08-07 07:37:13.477 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:13.470 am info parseResult: [WebSend:Done]

dev:842020-08-07 07:37:13.132 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:13.125 am info parseResult: [Time:2020-08-07T05:37:13, RfReceived:[Sync:12490, Low:390, High:1200, Data:F1DA5E, RfKey:2]]

dev:842020-08-07 07:37:11.719 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:11.712 am info parseResult: [WebSend:Done]

dev:842020-08-07 07:37:11.435 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:11.429 am info parseResult: [WebSend:Done]

dev:842020-08-07 07:37:11.036 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:11.029 am info parseResult: [Time:2020-08-07T05:37:11, RfReceived:[Sync:12250, Low:360, High:1160, Data:FEDAB9, RfKey:None]]

dev:842020-08-07 07:37:07.352 am debug tasmota_updatePresence(presence=present) DISABLED

dev:842020-08-07 07:37:07.283 am info parseResult: [Status:[Module:25, DeviceName:SonoffRFRM, FriendlyName:[Tasmota - SonoffRFBR (], Topic:RF_Bridge, ButtonTopic:0, Power:0, PowerOnState:3, LedState:1, LedMask:FFFF, SaveData:1, SaveState:1, SwitchTopic:0, SwitchMode:[0, 0, 0, 0, 0, 0, 0, 0], ButtonRetain:0, SwitchRetain:0, SensorRetain:0, PowerRetain:1], StatusPRM:[Baudrate:19200, SerialConfig:8N1, GroupTopic:tasmotas, OtaUrl:Tasmota-Hubitat/tools/fw_efm8bb1/RF-Bridge-EFM8BB1-20190220.hex at release-7.1-hubitat · markus-li/Tasmota-Hubitat · GitHub, RestartReason:Software/System restart, Uptime:0T00:00:58, StartupUTC:2020-08-07T12:36:08, Sleep:50, CfgHolder:4617, BootCount:62, BCResetTime:2020-07-29T00:03:34, SaveCount:123, SaveAddress:F9000], StatusFWR:[Version:8.3.1(tasmota-he), BuildDateTime:2020-07-04T09:54:39, Boot:7, Core:2_7_1, SDK:2.2.2-dev(38a443e), Hardware:ESP8285, CR:555/699], StatusLOG:[SerialLog:0, WebLog:2, MqttLog:0, SysLog:2, LogHost:, LogPort:514, SSId:[HomeRM, EstudioRM2], TelePeriod:300, Resolution:55C180C0, SetOption:[00008021, 280514000100060000005A00000000000000, 00000000, 80006000]], StatusMEM:[ProgramSize:595, Free:408, Heap:24, ProgramFlashSize:1024, FlashSize:1024, FlashChipId:144051, FlashMode:3, Features:[00000809, 8F8AE797, 043683A1, 000000CD, 010013C0, C000F1A1, 00000024], Drivers:1,2,3,4,5,6,8,9,10,16,18,19,20,21,22,24,25,26,27,30,35,37,95, Sensors:1,2,3,4,5,6], StatusNET:[Hostname:RF_Bridge, IPAddress:, Gateway:, Subnetmask:, DNSServer:, Mac:DC:4F:22:F7:EA:C6, Webserver:2, WifiConfig:4, WifiPower:17.0], StatusTIM:[UTC:2020-08-07T12:37:06, Local:2020-08-07T05:37:06, StartDST:2020-03-29T02:00:00, EndDST:2020-10-25T03:00:00, Timezone:-07:00, Sunrise:21:32, Sunset:12:18], StatusSNS:[Time:2020-08-07T05:37:07], StatusSTS:[Time:2020-08-07T05:37:07, Uptime:0T00:00:59, UptimeSec:59, Heap:24, SleepMode:Dynamic, Sleep:50, LoadAvg:19, MqttCount:0, Wifi:[AP:2, SSId:EstudioRM2, BSSId:A4:2B:B0:CD:24:9D, Channel:7, RSSI:100, Signal:-48, LinkCount:1, Downtime:0T00:00:03]]]

Did you install these drivers?

Correct. Those are the ones that I installed. But the parent driver is not generating the child ones. I have tried manually to add those, but I really don't know how to link those with the parent and is not detecting the RF codes. Thanks!

Your screenshots look like you haven't used the RF parent driver but the Universal parent driver?


Big thanks. I will be back home on Monday and will verify the drivers. Perhaps I did that mistake, due I download all the drivers and have been playing around with RF devices, trying to configure those. Have a good weekend.

@at9, it worked fine. Thanks again for your support. I deleted all the drivers and started from scratch. Since yesterday night I've been playing with the sensors, and for some reason (later I will find out what happened) the only way that it worked was following this installation steps:

  1. With the Tasmota Device Manager, I discovered the Sonoff RF Bridge
  2. It was setup as Tasmota - Universal Parent. At the devices, I changed the type for Sonoff RF BR
  3. I recreated the Child Devices
  4. Started Action Start Learning, and everything worked fine.

Thanks again for taking some time and help newbies. @markus, big thanks for sharing your drivers and knowledge.

1 Like

@jramonmorales, I'm very new at this so thats why im asking. How can you do step 3 and 4?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.