Some bulbs in scene require two calls

I have a scene that contains two types of zigbee bulbs (call them A and B). I found that when I activate the scene from a rule in RM, only bulb A turns on. However, if I activate the scene again bulb B then turns on.

I see the same behavior if I turn the scene on directly from the Devices GUI. I push the "on" button and bulb A turns on . I push it again and bulb B turns on. It's all very consistent, but I just can't figure out why bulb B needs to be called twice to turn on.

I tried deleting the scene and recreating it, same result. I finally figured out that I could "fix" this by calling the scene twice from within my rule, using a 5-10 second delay between the two calls.

Can anyone explain this? I tried searching the forum but didn't find much.


Does your scene include more than just "on" or "off" (e.g., setting level, color, or color temperature)? For a bulb, it likely does, given that Hubitat should capture all applicable states for the device when saving/capturing the scene (and similarly for recalling/activating it).

If so, there have been many people who've reported similar problems with all bulbs not "getting" commands the first time around if some of these are issued too quickly in a row. The next hub platform version, 2.2.5, is reported to have new bulb drivers that may help wit this. There is no timeline on its release, but if you don't mind waiting for whenever that happens, it may help. It also may not. :slight_smile: If you want to try something in the meantime, a couple ideas may help. Leverage Zigbee group messaging wherever possible, which in this case would only be if you have multiple bulbs that you want to set all to the same setting (create a group, turn on group messaging for it, and use that group in the scene instead of individual bulbs). Alternatively, with a rule or custom app, you could space out the commands a bit so the same bulb doesn't get certain commands too quickly in succession, which others have found to help. As an alternative to that, doing what you've discovered--just retrying the same thing a second or two later--can also help (so activating the scene, waiting a second or two, then doing it again--which would also be possible with a rule, a custom app, and maybe the right stock app).

Thanks for this information. Yes, I have actually three bulbs that I want to set to the same color/brightness/saturation here. When I first attempted to define the scene for this action, I indeed created a group to do it.

However I found I could not get the scene to work (it did nothing when invoked). So I instead resorted to defining the scene using the individual bulbs. I mentioned this in an earlier post about a week ago, it's unclear to me whether scenes work when defined using groups.

My current work-around of calling the scene twice is sufficient for now, so I'll probably just wait for the new hub update you mentioned.

I forgot to mention.... the problem doesn't seem to be related to successive commands being sent out too quickly. If I'm in the Device GUI for my scene, and just click the "on" button once, nothing happens. There are no other command happening at the time. But as soon as I click "on" again, the bulb turns on. It can be one second after the first click or 10 seconds, doesn't matter. It does the exact same thing EVERY time. It does not exhibit any intermittent or sporadic behavior, it's very deliberate. There is no issue with "off" commands, they work the first time.

That's a bit weirder. What does your Zigbee network like, and what kind (brand and model) of bulbs are these? It is generally recommended to avoid mixing bulbs and non-bulb Zigbee devices (e.g., smart plugs, dimmers, sensors, etc.) on the same network due to many Zigbee bulbs being poor repeaters for these other devices, which can cause hard-to-troubleshoot network problems. Usually I think it's the other kind of devices and not the bulbs where the problems will show, but I suppose anything is possible. Sengled is one exception here, since their bulbs do not repeat; many people also report better luck with newer bulbs like the Ikea ones, but I'm not sure anyone has objectively verified anything with a Zigbee sniffer (staff saw messages disappear before their eyes with several brands in the past).

My network is pretty simple so far. I have three Zigbee bulbs and one Dwave switch. Two of the bulbs are Sylvania Smart+ BR30's and the third is an A19, unknown manufacturer. It's the Sylvania bulbs that are the issue here. I've tried disconnecting the switch, it makes no difference.

All of my Sylvania Smart+ RGBW A19 bulbs require two calls to turn on. I thought it was just me, but it seems like an issue with the Sylvania Smart+ Zigbee bulbs. I'm using the generic RGBW Zigbee driver.