[SOLVED] Update Download Failed

Has anyone had issues updating your hub that can not be resolved with a soft reset and restore from backup? I am consistently getting a Download Failed message when trying to update from to on a C-7 hub that was purchased in November of last year.

I confirmed my internet connectivity and the download completes quickly and starts the download verification, so it's not stalling or timing out during the download but then it just fails at the end of verification. I have done multiple soft reset and restore from backup sequences. That led to a whole pile of additional errors and database issues (not sure if it was caused by the soft reset or just highlighted by it) that now seem to be under control after rolling back to my oldest backup version. However, I'm still at a loss for the update failed error, I don't have an explanation for the errors and crashes when restoring from a backup, and I am concerned that there is an underlying hardware issue. I've even tried to update from a "clean" start after doing a soft reset and not uploading a backup, but that fails as well.

I reached out to support two weeks ago and responded to their first level questions and followed their troubleshooting recommendations, but after that I got a note that it's been passed on to engineering. That was 9 days ago and when I emailed support again asking for an update all I get is "Our system does not recognize replies to this ticket, so you will not receive any further response. Support will reach out to you if additional details about this incident are needed." I'm getting pretty frustrated because I'm close to 90 days from purchase and I feel like I'm being strung out until I hit 90 days and they say "sorry - out of warranty, nothing we can do to help you". Any thoughts on how I can either fix this or determine it is a hardware issue to hold them to their warranty?

Tagging @bobbyD @gopher.ny


Thanks for reaching out, do you mind sharing the ticket number? I'll check on your case and will send you an update as soon as possible.


The ticket number is 25191
Appreciate you looking into this.

You've caught my attention when you said that you had a "pile of additional errors and database issues". If you had a corrupted database that continued to get corrupted after you ran the Soft Reset, your hub likely has a bloated trace file. Here is what I would do. First, remove the trace file by visiting the following page from your local network:


*replace hubs.ip.address.here with your actual IP address of your hub.

After you remove the trace file, please screen the Logs to make sure you are not dealing with any more problems. For good measure, I would take a fresh backup, then run another Soft Reset following below instructions and restore the newly created backup when prompted on the Get Started screen.



That seems to have solved the problem. By removing the trace file before doing a soft reset and restore, I was able to successfully complete the version update process and everything seems to be functional. I'm only at 30 minutes uptime after the restore and update, but I'm not seeing any errors in the log so far. Thanks Bobby!


Well I have the same problem. I tried to delete the trace file and it could not delete it. Any other things that I can try?

@bobbyD :point_up:

1 Like

Make sure that your hub is connected to the cloud. Mind sharing what version is your hub running, and what model?

Yea I am connected to the internet everything seems fine but can't update C-7
I get deleted files: [], could not delete: [] when trying to delete the trace files

1 Like

Fixed. Change network speed to auto-nogotiate.....works fine now


failed for me also. Can you indicate where the auto-negotiate setting is in the menus ? Thanks

Go to Settings then Network Setup, then Ethernet Speed.