[Solved] MP22Z Issue - Random ON Commands

Has anybody had issues with the Minoston Z-Wave Outdoor Switch turning ON randomly? I have tried rewriting/pausing/removing all of the rule machine scripts that touch the device, but the random ON commands have persisted. Aside from this issue it is a great outlet, but I'm at the point of removing and re-adding the device to the hub. I'm sure that should have been part of the troubleshooting already, but I haven't done that process yet so I'm hoping to avoid it.
Snips of the config/log info below. I've got the debug logging running now, but there weren't any clues there the last time I ran them.
Config:


Logs:

The digital commands in the logs were directed by HE as intended. The physical OFF commands were me turning the lights off whenever I realized they'd turned themselves on. The physical ON commands are the ones that don't have an obvious source and are driving me crazy.

Thanks in advance for any insights!

I have the dimmer plug-in outlet, but only had it set up a few hours, so no info on problem yet.

However, did want to make sure you were aware that there are Ministon Hubitat drivers avaialble here, on their GitHub:

I'm using the driver for the plug in dimmer and seems to work very well in my very short testing.

Oh, and random on commands are frequently caused by having the device in an automation that you've forgotten about. Have you checked the In Use By section at the bottom of the Ministon device page to check on what automations the outlet is being used in?

image

These devices can be configured to have auto-on and auto-off settings as well. It depends on the driver... but one of mine apparently came with the setting already configured to switch after 3 hours.

1 Like

True, the driver has a lot of settings, including auto-off:

I had no idea there were Ministon Hubitat drivers out there! I'll give this a shot and see if that does the trick. I've tried the 'generic' device driver and also the GE Embrighten outlet (saw it recommended in another thread), so maybe that's been the issue.

I have tried the In Use By section and I'm pretty confident I've ruled that out.

That also crossed my mind. The first device type that I tried had that auto on/off setting, which I made sure was disabled. The 'generic z-wave plus outlet' device type doesn't have that setting. In both cases, the phantom ON commands were still there.

If the updated driver doesn't help, then you may have to remove it, factory reset, and re-add it. Found this w/a quick Google...from Z-Wave Alliance web page:

Factory Reset:
MANUAL RESET ---Power off MP22Z ---keep holding the PROG button ---Power on,Press and keep holding the PROG button for no less than 10 seconds .

User manual link at the bottom of this page:

Do you use integrations with any third parties like Alexa? Alexa Hunches is well known for causing unexpected device behavior.

Thanks everyone for your suggestions! The custom drivers didn't work for the MP22Z, unfortunately. But I think I've solved this one by switching the device type to the pre-configured "Minoston MS10ZS Switch" type! I guess it's close enough :man_shrugging:

I have found the built-in EVA LOGIK drivers to work well with them.

Download the Hubitat app