[SOLVED] Motion Lighting App Null Error

I'm trying to use the Motion Lighting app for the first time. I click "Create New Motion Lighting App". The next screen says "Name this Motion Lighting*" and below that "Click to set" where I type in a name. The only other items on the screen are buttons for "Continue", "Remove" and "Done".

When I type in the name of the automation and then click "Continue" I get the following error message:
Unexpected Error
An unexpected error has occurred trying to load the app. Check [Logs] for more information.
Error: For input string: "null"

My HE version is:
Hubitat Elevation® Platform Version
Hardware Version Rev C-5

I just received my HE a week ago and so far love it (moved from Wink), but this is frustrating. I tried to remove the Motion Lighting app (several times) and add it back in, same result. I restarted the HE (several times), same result.

Am I doing something wrong or is something wrong with my HE? Any help is greatly appreciated!



Welcome to Hubitat!

Sorry about the issue you're having. I'm not sure what's going on (you do have motion sensors paired to HE, correct?), but I would recommend capturing logs.

To do this, have two browser windows connected to your HE at the same time. In the first one, try adding/creating a Motion Lighting automation, and in the second, keep the Log displayed. Take a screenshot of the log, showing the failure and post it here - it will help @bobbyD trouble shoot this issue with you.

Thanks for the quick reply! I do have motion sensors. The one I'd like to use is a Zigbee Hue Outdoor Sensor. It's brand new and is very responsive. But I never get to the point where I have an option to select it in the Motion Lighting app.

Screenshot of log:

Copy/Paste of the same log:
app:2152019-11-10 09:10:29.371 pm errorjava.lang.NumberFormatException: For input string: "null" on line 293 (mainPage)

Tagging @bobbyD @bravenel

I called it "Front Door". Here's a screen shot of that screen.

Yes, the motion sensor is paired. It is very responsive in the logs.

1 Like

I don’t think I have ever hit continue. I type the name and then click somewhere outside the box and everything else populates. I’m pretty sure about this, but not somewhere I can double check.

1 Like

I get the same error when I press "Continue" or click into the white space or press "tab".

There's another thread on this, something's currently broken.

I can't add a new one, I have two that error on edit, and one that works just fine.

Sorry for the troubles, this is a known issue that has been resolved and is currently in testing to be released with next update. We are sorry for the inconvenience.

As a workaround, please review the list of scenes created using "Groups and Scenes" app. One of them may be corrupt (empty) and needs to be removed. Worst case would be to completely remove Groups and Scenes app, and starting over.

1 Like

Thanks for the help everyone. I appreciate the rapid response from the community. Sounds like I just need to wait for the fix to be released.

1 Like

Oddly, I did find one scene that no longer had the switch selected, but since I could edit it, didn't appear corrupted, or even "empty."

I fixed it, but still can't get into those two motion apps.

FWIW, I was able to create (as a test) a new mode lighting app.

Will the fix sort this out without removing and recreating everything? I do have enough of all these that it would be quite a chore to recreate everything.

Also, is it possible to merge the two threads so this can be tracked in one if needed?

BobbyD sent me a workaround to this that worked for me. He said that the error is caused by a scene with a problem. I only had one scene so I just deleted it. That resolved the motion lighting error. While the scene seemed to work fine, there was probably something messed up with it or I'm just a noob and didn't have it fully setup correctly.

I look forward to a permanent fix or at least better error reporting.

Thanks everyone!


I am also having the same issue with the Motion Lighting App Null Error. I can not edit any of my existing, nor create a new one.

I reviewed my Scenes, which I recently built, and there is one that is set to Null, Looks like a duplicate of another one. Is there any way of deleting it? It is not in the menu.

To delete the scene, click "Apps" then under "Groups and Scenes" look for the offending scene and click the gear to the left of it. Scroll all the way to the bottom and click "remove this child instance..."

1 Like

Thanks, I actually had to delete Scene 209 which the Null Scene appeared to be a duplicate of. Once I did that, both scene entries disappeared and Motion Lighting became editable again.

Thank for this thread and for the help!

1 Like

I looked at the top level details on Groups and Scenes and saw the null= device. It was a duplicate of the scene that mysteriously lost its switch device. Not sure if it matters, but the scene was originally created as a clone and modified.

I removed it, verified they were (both) gone in the parent app, then recreated it and was able to edit one of the offended motion apps.


1 Like

I just started having the same issues tonight, after creating these 12 new Groups and Scenes.
Guess I'll try deleting them all and see what happens.


After doing some process of elimination, I found the one Scenes causing my problem.


After removing that Scene, I was able to open the Motion Lighting App again just fine.

Temporary fix without deleting all Scenes and Groups:

Open the settings for "Motion Lighting" (The gear icon) and scroll down to "Application State" and then the section labeled "registeredScenes". Look through the list for anything set to null. Delete and recreate any 'null' scenes on this list and then motion lighting will work again.