[Solved] Lutron Integration Null Pointer Exception

A few months ago one of our Pico remotes stopped working reliably. I finally got around to investigating and the logs show that the Lutron Integration in Hubitat is throwing an NPE:

java.lang.NullPointerException: Cannot invoke method toInteger() on null object on line 74 (method parse)

Is there some change that was made to the Lutron integration that I need to make a config change to match? I’d really like to get this remote working again if possible.

No changes have been made to the integration.
Is the correct pico button count assigned in the driver?

1 Like

I haven’t done anything in the device settings, only following the instructions in the wiki

Today I noticed that one of our pico switches still works sometimes, but it’s a 5 button pico (a PJ2-3PRL). The one that never works is a 4 button (a PJ2-4B). I’ve tried selecting various entries in the type drop-down but none of them result in a working switch for the 4button.

Check the "Set pico button count" in the Preferences section of the device page for the 4-button pico.


Wow thanks so much. I’m surprised this wasn’t documented anywhere, but hopefully someone who searches this error message will find it. Thank you!

1 Like