[SOLVED] Hubitat C7 2.2.9 firmware issue

I tried to setup my new C7 last night. I started out by updating the firmware to 2.2.9.136 and shortly after that to 2.2.9.137. Then I attempted to add a zwave device. When that one failed, i attempted a different zwave device, and then a third and then finally a fourth. I never found a single one of them. I did record several zwaveCrashed system errors. I scoured here in the forums and on google with no luck. My Z-Wave settings table was always completely empty and the logs never showed the hub detecting anything. I also attempted a zwave radio firmware update and that would just sit there looking for devices and never complete. This morning, I found that I could roll back to the 2.2.3.148 firmware that was on the hub. I did that and to my surprise, the zwave device table had an entry listed when I opened up the settings. Also, the zwave firmware update tool successfully completed. Finally, when I attempted to add a zwave device again, the hub found it almost immediately. The 2.2.9 branch of the code seems to have some serious zwave problems. Is this normal for hubitat updates? Is there a preferred software version and is there any way to load specific versions of the software? Going forward, what is the best way to archive software versions in order to allow rollback in the event of another 2.2.9 fiasco? Finally, when will there be a current stable version of the software that works correctly with zwave? TIA.

@altuser99 There was an issue with .136 and it was pulled, but your issues likely stem from ghosts. Share a shot of your z-wave settings page please.

Here is my current settings page. It is worth noting that when I was on 2.2.9, the 01 node did not show up in the grid. I assume that it represents the hub radio. Also, whenever I clicked on the zwave settings button in the interface, it took a good 10 or more seconds of thinking to actually load the zwave settings page.

well, when i try to upload the picture, i get the following error.
Sorry, you can't embed media items in a post.

That will go away when you have a few posts and days under your belt. In the mean time, on your Settings | ZWave Details page do you have any devices marked "Pending" or an empty Device Class column?

Nope, just 0x01 with a status of OK and 0x06 with a status of OK(GE motion sensor that I added after the hub downgrade to 2.2.3

Node Status Clusters Device Security Route
| --- | --- | --- | --- | --- | --- |
|0x01 (001)|OK|in: , out:||S2 Access Control||
|0x06 (006)|OK|in: 0x5E, 0x86, 0x72, 0x59, 0x85, 0x73, 0x71, 0x84, 0x80, 0x30, 0x70, 0x7A, 0x5A, out:|[Device]|None|01 -> 06 100kbps|

Also, just for fun, I just performed a zwave radio reset. The reset completed successfully. When I was on 2.2.9 this also would not work. I got an error whenever I tried it.

Should I just open a ticket with support about this?

A ticket might be in order as 2.2.9 seems to be fairly solid for most. At minimum let's ask @bobbyD if we can remove the image posting restriction so that you can post the errors for us to look at.

2 Likes

I fixed that. Your account was too new and there are some system restrictions to prevent spam.

I do recommend sending us an email at support@hubitat.com, knowing that this is the first time you are trying to include a device and the hub doesn't appear to find any. We just want to make sure the radio is functional. Please send us your hub's MAC address along with the email the hub is registered with, so we can further investigate.

2 Likes

Bobby,
As I mentioned, the radio works perfectly when I downgrade the software from 2.2.9.137 to 2.2.3.148. The zwave grid didn't even show the 01(controller) device when on 2.2.9. Since I have nothing to lose, I'll upgrade back to 2.2.9.137 and see if the issue persists. I'll also send an email to support.

Can you post a couple of these? It may prod someone's memory.

I just did a full reset of the hub and started fresh again with an update to 2.2.9.137. I'm seeing the zwave settings issues again, so I should be able to re-create the errors.

Something else interesting just happened. I have been trying to get the diagnostic tool to update since last night when I noticed that the version shown in the docs was newer than the version on my hub. The docs show 1.0.81 and my hub had 1.0.75. I just checked again for an update after the full reset and upgrade to 2.2.9.137 and this time is actually updated to 1.0.92. This is really strange.

Looks like I've already managed to get two zwave crashes since re-updating. I haven't even tried to join any devices yet, I've just gone into the settings. I just timed the amount of time it takes from clicking on "Z-Wave Details" to actually load the page. It took 1 minute and 50 seconds for the page to load and the grid is once again missing the 01 device.
Screenshot 2021-10-21 141044


I'm beginning to wonder if there was an intermediate update that wasn't rolled into the 2.2.9 from the 2.2.3.

Those don't look good at all. Any ideas @bcopeland ?

Also, notice that the event times appear to be in GMT even though it says CDT.

Here's a shot from when i downgraded to 2.2.3.148.

Are you referring to the Z-Wave Topology Map? Or, instead, the table of Z-Wave devices on the Z-Wave Details?

The Hub (controller), Z-Wave device 01, was removed from the list of devices several releases back.

Download the Hubitat app