[Solved] Hub Link/Link to Hub not working

Edit: It did not fix the problem.

Edit: I rolled back the hubs to and will see if this fixes the problem.

I'm not sure when this started exactly. I have two hubs. The first is a C4 hub that has all of my HA1.2 and higher devices. The second is a C5 hub that has all of my Iris V1 devices. Until recently, these have operated through Hub Link/Link to Hub without issue. However, in th epast few days, I noticed that events that depended on the Iris V1 motion sensors are not taking place. The app is on the C4 hub and the Iris V1 motion sensor that got me looking is on the C5 hub. It isn't only this, but another light that is supposed to turn on when motion is done is also not turning the light on. Again, the app is on the C4 hub and the switch is on the C5 hub. If I go to the C5 hub and toggle these two lights on and off, it works. However, from my C4 hub's dashboard, it also is not turning the lights on and off although the dashboard button changes color to indicate the light is on. This is jMy suspicion is that something in the latest update just not right.

What could be happening, and how do I fix it? I suspect that something in the update has something to do with this.

I have used Hub Link and Hubconnect. Hubconnect is much more robust and reliable, at least in my experience, and in many other's experience as well. I also have my suspicions about the latest update, but even with that update, Hubconnect is running great.
Installing will require about 15 mins of copy/paste, but it is time well spent.
Check it out:

It turns out that the hubs were not the problem. Somehow, my Netgear Nighhawk router had stopped routing internal addresses, so none of my devices were communicating properly over the Lan. The strange thing is that they were talking over wireless through the same router. After a number of steps, including swapping out for my old Linksys router and finding internal was now routing but no Internet access and then swapping back to the Netgear router and a few reboots of cable modem and the router, everything started working. Why? I have no clue. I am just happy that it is working again. If I can, I will mark this as solved.

1 Like

Okay, my previous reply turned out to not be the solution. This one is. Netgear put out a firmware update that was the cause behind this behavior. I finally got on the Netgear community forum and found out that I was not the only one having problems. The solution given was to downgrade the firmware, which I have now done. Everything is behaving and I will certainly blacklist that particular firmware and not allow it anywhere near my router. Hopefully, this won't be a pattern.


I feel your pain, years of bad netgear firmware lead me to Merlin, best thing I ever did. I've moved on to pfsense a few weeks back. Simple to setup and very powerful and runs on pretty much any old hardware you have running around. Along with a Unifi AP and I'm getting a 95% less complaints from the wife & kids, like "the wifi is wacked" or "what are we? Amish?"

Please expand on this. What is Merlin? Do you have a link? My searching does not lead me to anything that seems like it fits. I did see pfsense. If I understand, it is a free download, but any support would be commercial.

Sorry. So Merlin is a 3rd party firmware for netgear routers, as long as your model is on the list. I have an R7000 and when I got sick of netgear's constantly bad firmware releases, I flashed my router to Merlin.

Check that your model is compatible and others have performed the flash on your particular model router.

and here:

as far as pfsense, if you watch a couple youtube videos, you'll see it's very simple, download, run file, boot pfsense. I doubt you'll need support, it's a very solid platform and just works
This guy did a good job. I installed as I watched the video and just kept pausing it as I worked the steps.

1 Like

One addendum to this topic.

After getting things working again, I noticed that one of my lights was not behaving properly. It is plugged into one of my Iris V1 outlets connected to my C5 hub. The others were behaving. This one was not responding to my dashboard on the linked C4 hub that is the hub that controls all my automation. I could use the dashboard on the C5 hub to turn the light on and off, but not the dashboard on my C4 hub. When I pulled up the device on the C4 hub, I noticed that the IP address was missing.

After trying everything else I could think of, I finally removed that tile from the C4 dashboard. Then I went into my apps and removed any reference to that linked device from any app that used it, to include automation and HSM. Then I deleted the linked app. I also deselected it as one of the devices to be shared from the C5 hub. Then I deleted the device from the C4 hub.

Next, I added the outlet back into the devices to be linked on the C5 hub. I then created a new tile with the new linked device that showed up. Last, I added that new linked device back into all the automation and HSM applications. After all that, the Iris V1 outlet is working properly again. Now that I have done this, if I see one of my linked devices misbehaving, I will know better how to troubleshoot it and, if needed, what to do to get it working again.

What I don't know is why it stopped responding, especially since the other two Iris V1 outlets were working properly. I don't know if this will assist anyone else, but I did want to put this here in case it might assist someone else (and to remind me if it happens again).

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.