[SOLVED] Hub C-5 not loading after changing router


#1

I’ve been Hubitat user since May 2019 and have had a great experience. I have the Hub Model C-5. However, today instead of gracefully shutting down my hub from the UI, I unplugged it to save time as I was reorganizing my devices on my power bar.

This has caused the hub to stop working at all unfortunately. Now, when I power up the hub, the light first turns blue then green. After that the hub is failing to get an IP address from my router as it did before I unplugged it, so I cannot even log in to troubleshoot. I looked at my router logs and the hub’s network interface is repeatedly going up and down. Can someone please help me fix my hub?

Here’s an example of what I’m seeing in my Asus router:

Aug 13 18:51:37 kernel: eth4 (Ext switch port: 3) (Logical Port: 11) Link UP 100 mbps full duplex
Aug 13 18:51:41 kernel: eth4 (Ext switch port: 3) (Logical Port: 11) Link DOWN.
Aug 13 18:51:44 kernel: eth4 (Ext switch port: 3) (Logical Port: 11) Link UP 100 mbps full duplex
Aug 13 18:51:51 kernel: eth4 (Ext switch port: 3) (Logical Port: 11) Link DOWN.


#2

I think it's best you contact support at
support@hubitat.com


#3

Hey @stephack,
I did I got a less than helpful answer, I don't feel like support read my message carefully. Their solution asked me to go to a URL that requires my Hub's IP address, which is what i said was missing in the first place. Anyways, if someone else has any suggestions, I would highly appreciate it.


#4

Can try a different network switch if possible and see if the hub comes up?


#5

I don't think anyone knows what happens with an in-progress write to flash drive when power is pulled -- what gets written or overwritten, what bits get mangled --

My guess is that this hub won't come back... Do you have a backup of your database? If so, contact us at orders@hubitat.com about getting a replacement.


#6

Hey @patrick
After much trial error, it turns out that it doesn't like my new ASUS GT-AC5300 router ports. My older router was a Netgear R7000, where I used to use a cheap USB powered hub since 4 ports just wasn't enough. When I connect my HE hub to --> cheap hub --> my ASUS router it works fine!
The whole objective was to get rid of the cheap hub, but at the end, it's what saved me.

So although the support response didn't help at first, the rep was right when he said: "We have been investigating an incompatibility between Hubitat Elevation's Ethernet port and some Netgear and Asus network switches and a fix is currently in testing."

Thanks for the help folks. In 3 months, my setup has really matured with all kinds of devices, lights, sensors, cameras, IFTTT, with my last addition being a wall mounted fire tablet running the HE dashboard and Wyze camera streaming via tinycam pro served using my Nvidia Shield. I really want to do a detailed write up or a video of what i learned so others may benefit, but really impressed with the vast network of help on this forum.


#7

If you now do what support recommended, you can enable a fix we have for those Netgear switches.

It's still in internal testing but we have had good success with the fix.


#8

Okay will try it out.

Update: the fix worked! Now I can plug in the HE hub directly into my ASUS router.

Thanks @bobbyD and @patrick


#9

5 hours for getting from nowhere to a better setup and working through an issue which was a riddle to say the least. There are a lot of companies in the world where this would take weeks to solve. I'm impressed!