[Solved] Device Doesn’t Update Status After Rule Execution


#1

I have a very simple rule:

If cabinet lights on, turn on island lights. Turn off island lights if cabinet lights off (false).

It works. The problem is when I have both lights on and manually turn off the island light, the island light switch goes off but the status remains on.

The island light switch is a Cooper Aspire switch so supports Instant Status. Status updates correctly when the rule is not executed first. I have to hit the refresh button to update to the correct status after the rule is executed and I manually turn off the island light.

Edit: Also - the log does not register that the island switch was turned off. I checked an hour later and the switch does not update status in later polling.


#2

What driver are you using with the Cooper Aspire switch?

Does the status get updated correctly when you just turn the switch on and off, and then stop being updated after the rule turns it on? Very odd!


#3

That’s exactly it. While the rule is True the status is stuck at On until I turn the Cabinet Light off and the rule changes to False.

While it is stuck at On the Island light doesn’t log any activity even though I’m manually turning it on and off.

I also tried this as a trigger rule and it’s the same deal.


#4

Could you show the rule as you have it setup.


#5

I’m using the generic zwave smart switch driver. I’ll do a screen capture of the rule when I get home this pm.


#6

You have the Aspire z wave dimmer? Is that z-wave or z-wave plus? There are a few different models and I wasn't sure. If the one your have is non-plus (regular or classic) z-wave, you should be using the Generic Z-wave Dimmer driver. The Generic Z-wave Smart Dimmer driver is designed for Z-wave Plus dimmers, not Non-Plus dimmers. When you use a non-plus dimmer, you will have to use the Z-Wave poller built-in app to update the device's status in HE to physical changes to the device. Not updating to physical changes is a classic symptom of classic z-wave devices.
I tried to look some of the Aspire up to figure out if they were z-wave plus or not and was just more confused. They are called smart dimmers but then they only mention Z-wave, not Z-wave plus. When you paired the device, did it pick the Generic or Generic Smart driver?


#7

I have a non-dimmer zwave Classic switch. Cooper was one of less than a handful of manufacturers that was licensed to use Instant Status updates.

It also updates immediately to physical changes when the rule is false.

Hubitat didn’t recognize these switches when I included them and set them up as generic zwave devices. I had to change the driver to generic zwave smart switch.

It is very peculiar.


#8

After you manually changed the driver and saved the device, did you remember to click the CONFIGURE button on the device's page? Clicking CONFIGURE sends the Z-Wave configuration parameters to the device, telling it how to report status updates to the Hubitat hub. If this doesn't take care of the issue, I'd recommend trying to use the "Generic Z-Wave Switch" driver, instead of the "Generic Z-Wave Smart Switch" driver. These two drivers are very similar, but different in what they expect from the switch as far as reporting status updates.

Note: Had the device been discovered and paired with a known driver, the CONFIGURE command would have been automatically run. Manually changing the driver requires the manual press of the CONFIGURE button.


#9

I’m pretty sure I did that because it wasn’t working as a device, but I’ll do it again when I get home to be sure. I’ll also try the other driver.


#10

Thanks for all of the assistance!! It turns out these switches did better with the Generic Zwave Switch driver instead of the Generic Zwave Smart Switch driver. Everything seems to be updating correctly now.