So… I got a whole box of UZB3 sticks

I ordered one… Not sure what I would do with all these so probably going to see if they want them back.

2 Likes

Or sell them :joy:

1 Like

Are these the sticks that can be used for ghost removal with pc controller?

Yes

1 Like

Yes I think so, and can also be used as a sniffer if you re-flash it which is why I bought it. I ordered a 700 chip stick also but only got one of those not a whole box.

2 Likes

If you use more than one at a time for ghost removal, just be sure not to cross the streams.

13 Likes

So glad you said that. Too many people make light of the danger. :wink:

3 Likes

That would be the honest thing to do.

3 Likes

Maybe they thought you wanted 700 sticks?

7 Likes

I saw what you did there. :wink:

3 Likes

I read ghost nodes go away by themselves after some time. Is that not true?

I have not had issues with ghost nodes. Reports on this forum suggest the stick is the only sure fire way to kill them.

2 Likes

As @cwwilson08 indicates, using an USB stick just works. It can be a bit of effort to initially setup the software, but once in place it works well.

1 Like

Only if the device whose incomplete pairing caused them is not powered, i.e. remove battery, or disconnect from mains.

1 Like

So one of my Zooz dimmer switches was not responding and the Zooz support team asked me to exclude the device. I didn't want to lose the automations so instead today I did another inclusion that generated a new working dimmer switch. I then force removed the original, unresponsive device. The original device no longer shows up in my device list but this is what the original entry looks like when I go to Settings->Zwave details:

Will that entry go away on it's own or do I need a UZB stick to remove it? I've already tried the remove button shown but it just refreshes the page and does nothing. I don't notice any sort of performance or other ill effect of the entry being there but it's my OCD that wants to have it removed.

Anytime you are clicking buttons on this page it is a good practice to have another browser window open and view the live logs at the same time. With refresh and remove etc, the page can refresh quickly but the command is still being executed in the background. The log window give you insight to what is taking place.

In your case the ghost device will not be removed automatically over time because the physical device is still powered and in the mesh. You will not be able to manually remove it from the zwave details page either while the device is still powered.

Yes you need to get rid of it even if you are not noticing any issues.

Since it’s a dimmer, you can pull out the air gap on the switch and on this page try clicking the remove. It may take care of it for you. If it doesn’t work after a couple attempts, next I would suggest shutting down the hub, pull power for a minute, boot back up and try again.

3 Likes

The advise @steve.maddigan is solid for how to remove the ghost.

Next time you have to re-include a device try doing a "Replace" as I have outlined in this post. So far I have used it on various devices and it works great if you follow the correct steps.

1 Like

I did try those exact instructions but I got the following:
image

I also tried to move the hub as close as possible to the switch but same issue happened. I tried multiple times over a couple of days and nothing was successful. That's when I finally resorted to doing another inclusion and just replacing the old device with the new one in all apps and automations.

This is what's making me start to lean toward zigbee over z-wave. There is too many issues with onboarding and device management that I don't experience with zigbee. Or perhaps it is strictly related to Zooz switches. Either way it's frustrating.

I think I got that immediate status failed once. I powered off the hub and pulled power from it to reset the zwave radio, that solved it.

I even got a battery powered motion sensor back in on a replace yesterday. Not sure what happened but it just stopped working and I ended up just getting it to factory reset and got the replace to work.

I think the frustrations with zwave come from the 700 chip SDk in the C7 which Hubitat is at the mercy of Silicone Labs. It is slowly getting better.

3 Likes

Yeah I bet that's it.

For troubleshooting, I safely shut down my hub and repositioned closer to the switch. I also tried pulling the airgap multiple times. I also tried triple tapping more than once during a replace in case the inclusion on the switch timed out. None of that worked for me unfortunatley.

Download the Hubitat app