Smartthings button compatible?


#1

My wife's not a great fan of controlling the HSM and other essential things via app or browser. That's why I thought it would be nice if I can get her a few wireless buttons.

I've looked into the Smartthings button ( GP-U999SJVLEAA) but I'm not sure if it's fully compatible with Hubitat since it's not on the list.

Can anybody share his/her experience?
Or are there good/better alternatives?


#2

It is on the compatible list and works very well. It is magnetic and also reports temp and battery.


#3

Thanks, great to hear that it works but I can't find it on that list.

https://docs.hubitat.com/index.php?title=List_of_Compatible_Devices


#4

It's there.


#6

I use 2 of them to control our bedside sconces.. Did not want to put light switches on either side of the bed and the sconces are too high up to control comfortably. Used sengled smart bulbs and 2 smartthing buttons. One click toggles the related sconce. Double click toggles both. Working well.


#7

Is that "V5" the same one as this one here? Because I don't see any reference to "V5".


#8

Yes. There's really only one generation of the Samsung SmartThings Button, and it's this one (new in 2018). I don't fully understand Hubitat's naming system here, but it came out at the same time as their 5th-generation motion sensor (and all their other new 2018 ST devices), so I guess it got the number from that.


#9

Thanks for clarification.


#10

Not to be a downer in this thread but I have 5 of the buttons and when they work, they are great. But a lot of times the same command (tap / double tap / held) is received 3 times by Hubitat. I say received, because I haven't figured it out yet - is it the device sending it 3 times (I should check for a firmware upgrade), is it my mesh (could be, but only this device seems to have the issue), or is it Hubitat? No idea at this point. Actually, that is how I found this (slightly) older thread because I'm researching now.

I assume some people wouldn't see the issue if "single tap" for example, only did one thing. But I have it set to toggle, so sometimes it toggles twice or three times on a single press.

Taking out the battery and / or re syncing it seems to clear it up for a while.

I very much like the buttons, they are small, magnetic, and I just like them! So I guess I would recommend them. But still felt the need to post issues I'm seeing. It's possible the solution to my issue is even on these forums, hence my searching tonight!


#11

SmartThings firmware 24.2 had an update for the Button firmware. I have 5 of them and they haven’t given me any trouble


#12

I gave up on mine. I don’t own a Smartthings hub so am out of luck on trying a firmware update. Replaced it with a Pico remote for bedside use and am back in business. Love the form factor of the button, and when it works it’s great. Just got tired of pressing it and nothing happening.


#13

I am not seeing this behavior. I use toggle functions for several things.

Where do you see it 3 times, the device events or the logs? If it is in the device events then it is the button. If it's just in the logs and not events, it isn't. This would not explain why re-pairing or pulling the battery temporarily fixes it but I had one of my buttons setup in the button controller app and then used it as well in some other apps or rules and I seem to recall each would generate a log entry. My memory is getting so bad. But checking each will tell you where it is coming from.


#14

Ken_Fraleih,
So do you update the buttons via ST? I too have had a pretty bad reliability issue with them.


#15

Wanted to thank everyone for the advice. I feel I have derailed this thread a little. I apologize @concan !

I think I'm done playing for now. This week (before I got / could test the suggestions) I had 2 of 5 duplicating. One I took the battery out and put it back, the other I replaced the battery.

All 5 appear to be working fine now - right when I want to test them. So, I'll wait for one to mess up again and take a look.

I also just started up my SmartThings hub and checked this as well. I had just done the same in June. The hub and the buttons appear to be on the latest firmware, and no update to the buttons since the last time I tried.

Hub: 000.026.00012
Button:
image

I'm wondering if maybe the batteries need to be fully replaced with new ones to keep the issue from returning. I think all besides the one I changed are on the batteries that came with them. I'll pay attention to which of those two I fixed messes up first - the battery I fully replaced or the one I just took out for a minute.

Another idea, is possibly they don't like being on channel 25. But that's a bit of work to move all my devices that are working fine over.

Thanks for all the help everyone - if it happens again, I'll create a new thread.


#16

Yes. Enable OTA updates and pair the button with ST. Sometimes it updates as soon as it’s paired.


#17

No problem at all. I actually purchased 3 of them and they work perfectly. I’m very pleased.


#18

I actually had issues with one because the contact wasn’t connecting. I pulled on the back contact and side contact to make sure it connects better to the battery and that fixed it. Funny thing is, I had the exact same issue with an Ecobee sensor.