Smartly inject not working in 2.3.3

Anyone else still using smartly inject? Just tried to add a tile and resize it. Still works to let me work with the tiles but the save button does not seem to work. Says it is saving but when you exit or refresh it isn't saved.

The bug thread seems abandoned but I did post there as well.

Thanks

2 Likes

Yeah, it's failed on 2.3.3. Nothing intentional on HE's part, but something has changed that means nothing gets saved any more, for new or existing dashboards. What has been set up will still work/look the same, as far as I can tell.

Maybe there's a dev that will step forward to pick it up.

2 Likes

Will.take a.look as i still use it.

4 Likes

Any errors in.logs when saving?

Thanks for peeking at it. :slight_smile:

I haven't looked, frankly. I'll try it now and see what I get.

1 Like

Not seeing anything in the logs at all when I save a change.

Didn't see an option to turn on debug or other logging in the HE Dashboard app, parent or children. Never noticed this before, that there was no debug logging option for dashboards. (At least none that I see.)

Ah! Found it - there is debug option in the dashboard itself...still no logs in Log tab, and zero logging in the dashboard log window when using SMartly to change the size of a tile.

1 Like

More oddities...if I click on the Smartly injector virtual device this overlays the device display when the Device page opens for the injector...don't remember this happening before:

Click on this:
2022-10-16 16_09_08-Chrome Main

Get this: Hitting ESC or clicking on it doesn't do anything. Only way out is to use Back button on broswer (Chrome current version, and same result on Firefox) to return to the Device list.

And same result if I create a new Smartly injector virtual device. Very funky...

ok more info.
the dashboards and dashboard code works ok.
you can create new dashboards or copy dashboards using smartly.
they display fine and you still can use the smartly website to modify dashboards.

what doesnt work is the smart injection object on dashboards .
that basically is only for moving stuff around on the dashboard anyway,
yes it does not work and saving does not work
you still can modify and move stuff around on the dashboard the old way .

there are no errors in the logs when attempting to use or save the smartly dashboard using the smartly save option
so there really is nothing that can be done by us and i doubt hubitat support is going to jump in and look at the issue,, hopefully they will prove me wrong.

1 Like

Either side of line 8021 in the inject javascript file is likely where we need to look, though I may have an old version...

Does anyone have an old platform version running smartly? I would be interested to see how this section looks (including below the one highlighted):

1 Like

I don't think that is it

At least in mt case the javascript apoears to act normally and thinks its saved the changes.

Just when i reopen the dashboard
They haven't been saved.

The output in the console (I think) would suggest it couldn't find the Layout JSON text area and so could not update it and click save. At least that is my theory. The search it is trying to do I don't think would resolve in the HTML output on my test dashboard, but if I could see an example dashboard HTML from pre 2.3.3 then it might help prove or disprove that theory.

1 Like

Watching closely as I am a heavy Smartly user... only way I can get my wife to actually use the HE app.

This is why I should have a third hub that I rarely update so I can time-travel back farther. Thank you for justifying that purchase... :slight_smile:

3 Likes

I have 4 but am still too up-to-date.... :slightly_smiling_face:

2 Likes

Uh oh...so the I should have another hub thing is a slippery slope. :wink:

Maybe @csteele - IRRC he has a history of having too many hubs. :slight_smile:

2 Likes

I guess the moral of the story is you need 5....

1 Like

I have 5 active, 8 total.

2 of them are C-5's and I'm starting to miss not having individual ZWave repair and Replace.

My C-3 and both my C-4s are back in their boxes for the past year or more, retired forever. :smiley:

2 Likes

Got any running pre-2.3.3 (or able to roll back to pre-2.3.3) that you'd be willing to put Smartly on to do a quick test for @sburke781?

My understanding is he'll send you a C-1 pre-production prototype (made of cardboard and playdough) as a reward. :slight_smile:

3 Likes

I don't actually know what Smartly is...

Screen Shot 2022-10-17 at 10.05.40 AM

but I do have a C-7 Hub able to roll back to 2.3.2.141

2 Likes

Download the Hubitat app