SL controlling Group, Turn On and Set Level, dimmers good, switches not

Hi, since groups 2.1 I am seeing the switch members of groups of groups not getting turned on, but dimmer members do get turned on when triggered by Simple Lighting.

I have several Groups such as Rear Lights and Driveway Lights that each contain 1-5 devices, mix of switches, bulbs and dimmers, some zigbee some z-wave. They work fine when turned on and off individually from the device page or dashboard. All members go on and off as they should.

Then I have a Group named Outside Lights that has these zone groups as children/members. The only option is to choose the sub-zones as Bulbs. With Groups 2.0 it all worked great. The other day I went ahead and rebuilt all my groups to 2.1, now Im seeing only the dimmer device in each zone is getting turned on when the master goes on at sunset controlled by Simple Lighting. The switch devices are not seeing the on command. When I saw this the past 2 nights, I went to my dashboard and clicked the Outside Lights group device off and on, and voila, all the members went on.

So there is a difference between the turn on and set level command triggered by simple lighting, and clicking the button on the device page or dashboard? Or could it be that the hub is busy and the nested groups activity is causing queued commands to be dropped?

I originally had on/off optimization enabled, but turned it off hoping it would fix the problem, it didnt make any difference.

image


Try turning on the option "Use group device to indicate is any members are off". See if that fixes it.

Would that be on the master group, or the member sub-groups? both?

Whichever one is not working correctly. Not sure what's going on, just a thought of something to try.

No dice, same behavior. The dimmers get set, the switches dont. Its like the SL 'turn on and set level' command hits the dimmers, but then the group code exits and never send the on command to the switches.

As a test, I made a new SL just controlling a simple single group of a dimmer and a couple of switches, no nested groups. I got the same result, the dimmer was turned on, the switches weren't. I would guess you can reproduce this.

Looks like its the '..Set Level' part thats causing the issue, if I adjust SL to just send Turn On, the group members all go on.

Yep that's what did it, had groups that weren't ON when one light in the group was on, so therefore it never turned off when a parent sent an OFF signal.

Thanks for the help,

Robert