Skipping a certain song on Echo

I am normally a pretty chilled person, but this year it would seem that when we have Christmas playlists in our house this ONE SONG plays every 10 minutes. I will let you guess what it may be, I have created a rule that skips any tracks by the artist but it takes around 20 seconds for RM or even Echo Speaks to detect the song? I am wondering if anyone else has anything similar or even quicker way of stopping certain tracks from playing (Without creating my own play list of course)

Not a Hubitat solution, but I think giving it a thumbs down in your Alexa app or on your Echo Show (if you have one) will stop it from playing on your devices. That tends to be my approach...

Maybe there is an option in Hubitat to do this as well, but I haven’t noticed it...


You can also say “Alexa, thumbs down” whilst it’s playing, on any echo device.


Christmas will be over soon.

1 Like