Simple Lighting App - couple of issues

I have been experimenting with the Simple Lighting built-in app and have discovered a couple of issues...

First, I just want to turn on a bulb at "A Specific Time", but when I select that option, my screen refreshes and I see the following screen with no option to enter in a time, or save the rule.

If I select "When the Mode Changes" instead, I at least can select a Mode as shown below, but there is no option to save the new rule, unless you open the "Restrictions" section. Seems weird to have to open that up to me. Also, after saving that rule, I went to the LOCATION section and changed my mode to try to test the rule. Doing so did not result in the rule running. Any thoughts?

UPDATE: I tried using Mode Manager to change the mode from Evening to Night (yes, I changed the SL Rule to use Night as the trigger, once I realized Mode Manager cannot set Away based on Time :wink: ) to trigger my Simple Lighting Rule to turn off my bulb. Mode Manager worked as expected. But the bulb did not turn off. Simple Lighting seems to be having a bad first day... :frowning:

FYI - I am using Chrome on Windows 10.


Dan, You just discovered two bugs. Thanks. Will be fixed in next release. Or maybe three.


I was able to create a mode-based trigger in Rule Machine to cause the light to turn off when the mode changes to Night. So, at least the device is working as expected. I also noticed Rule Machine requires the “Restrictions” section to be opened before you can click the “Done” button.


Yes, you get the prize for discovering the hidden section bug. We added those at the last minute…

Both the certain time bug and that bug have been found, and will be fixed in next release. I’ve got to try to replicate your light-not-turning off bug.


I just added a Zigbee Contact Sensor. Using that as the trigger in Simple Lighting works as expected to turn my light on and off based on closed/open states.

1 Like

Found the mode change bug also. So, all three will be fixed next release. Thanks for the help!


Was the mode change bug in the evening 2/3/18 release? I have a motion lighting rule setup to change level on a switch with modes and it never changed the level. I have another issue with mode manager not changing the mode. So to test the lighting rule I manually set the mode. Light level didn’t change.

The mode change bug was specific to Simple Lighting. If you have some other issue, you would need to give me more information about what isn’t working, what the rule looks like (screen shot), etc. Same goes with mode manager, share a screen shot of its main page to show what you’re trying to do that isn’t happening.

It is certainly possible that you may encounter bugs here and there in these apps, as they have not had a lot of users banging on them. We will turn around fixes pretty quickly.

Still waiting for the “At Specific Time” bug to be fixed.

I am all in for supporting a new product or way to do things. I do have to draw the line at really basic things. Time Of Day is pretty simple. And, just to be a bit more aggravating, there’s no example of format. Is it, 3:00 PM, or 3:00.00 PM or 13:00 or 13.00.000? I’m guessing that most of us are coming over from Smartthings/WebCore. Certainly I am. This may create some issues if there either isn’t a consistency in input convention OR a minimal amount of documentation regarding input.

I’m really wanting to support this. My frustration is that some of this stuff is either porting or coding basic stuff. Fundamentals shouldn’t be a problem. Integration with a thousand other z-wave, off-label, programmed by some drunk… should be :slight_smile:

And…just for kicks, I tried the Simple Rule Machine. I tried to set “certain time” for 11:00 PM. When I entered 23:00, the next screen showed me 3:00 AM

What version of firmware are you currently running? I just tried creating a Simple Lighting rule use "At Specific Time" and it worked perfectly. I am currently on

These bugs were fixed and released the day after they were reported.

What browser are you using? Time inputs are HH:MM:AP --> e.g. 03:00:AM or 11:30:PM, using 12 hour clock with AM and PM, not 24 hour clock. Times in local time zone.

1 Like

Safari on macOS High Sierra



Sorry I got the upload out of order. The second one shows me setting the time to 11:00:PM and then the first screen immediately follows. This happens either in the Simple Lighting Rule or in Rule Machine

You shouldn’t have a colon between your minutes and “PM”

1 Like

From an earlier post:

That would be why I tried using the colon.


So I downloaded Firefox 58.0.2 and it worked. What is interesting is that there are a series of dashes and colons in this form:

Oh, wait. I was using Chrome.

Yes, it appears that Safari has some issue with time input. That's very weird.

We will investigate. Sorry for the wrong answer. !!

1 Like