Simple delay not working

I'm new to Hubitat and have been running everything with no problems except for turning off my coffee maker. I have way more complicated rules for other things but this one won't work correctly. I have it come on a 0440 in the morning which it does under simple automation and I have it turn off at 0600. It's all under the same rule entry. It never turns off. So then I used the rule machine to create on at 0440 and delay the off for 1 hour 20 minutes which is 0600. It never turns off. So now I'm back to the simple automation with on at 0440 and then I select done. Then create another simple rule to have it go off at 0600. This works. Why won't it turn off if I use 1 rule entry for both on and off? I'm using a C-7 hub and the on/off switch is the Aeotec heavy-duty 40 amp switch and that is using generic z-wave switch driver. Is there a better driver for this switch?

Can you post a screenshot of the rule here? That would be helpful.

Well, this didn't work this morning either. It always turns on but can't get the thing to turn off.

It just dawned on me that maybe I need 1 hour, 20 minutes rather than the 6 hours and 0 minutes. Let me try that.

I see that's not right and put it back to 0600. I also added to also turn off on the 0440 rule so I have 2 requests now to turn off at 0600.

That's the Simple Automation app? Weird my turn on and turn off prompts do not look like that. I just ran this test:

And it worked. Maybe delete what you have and make it from scratch?

I don't know if this applies to your case. But if all else fails after your testing/debug, and everything stills looks OK, Try setting the 'off' time to 5:59. I uncovered a weird quirk in HE with my automatic shades that they, for some reason, will not open/close 'on the hour'. 6:00, 8:00, etc doesn't work but 5;59 or 6:01, 7:59 or 8:01 work perfectly. I've deleted and re-created the rules, but on the hour doesn't work. I went back and forth with Bruce with logs and tests and it has him baffled, too. All my other automations work fine 'on the hour', just the shades do not. HE thinks it's operating the shades but they don't move so there's something wonky going on but it's so minor that I just live with it. It's a long shot that it would solve your issue, but it's a really quick/easy test to do.

Outstanding, that's exactly what I'll do. I'll report back. Thank you.

When testing again yesterday I had used a time like 0711 because that was a time that was just a few minutes away while I was creating the rule. That worked so I moved it back to 0600 and it didn't work this morning. I think that having it on the top of the hour might be the problem like Mark suggested. I have it at 0559 now so we'll see tomorrow. Thanks for all the input.

Setup a test....


So it looks like it will work at the top of the hour. At least mine does.

@tivomaniac , It's a weird scenario for me, all my 'normal' receptacles and switches work fine, it's literally only my shades. I mentioned trying it because it looks like he's using a more unique device being the 40A switch.

I had a Leviton 15a plug/switch before with an older coffee maker and it was spot on with the same instructions. I deleted those instructions and started fresh with the new switch. I'm using the same generic driver with the new Aoetec switch. It cycles on/off with the tiles fine. I got it to cycle off using a time that wasn't at the top of the hour. I'm curious to see what it does tomorrow with it at 0559.

That is weird. Well 1 min probably doesn't matter.

Yea, that's why I didn't bother Bruce anymore with it. It was so specific and such a minor issue it wasn't worth pursuing especially when they were in the middle of the ZW stuff.
And it drove me nuts, I'd run test after test and it would work fine everytime, but I was doing what @legends08 did; I was setting a time like a minute or 2 away from the current time so I can monitor the logs, etc. On a 'what the hell' whim I did some controlled tests over 4-5days and every x:59 worked perfect and every x:00 didn't and it was repeatable. I mentioned that to Bruce and he said he didn't have a clue what could cause that so I just let it go figuring that maybe sometime in the future an obscure bug may be found and corrected.

Well Mark I think you found the problem. This morning was the first time that switch turned off via the rule/automation. It is set to turn off at 0559. Might be too soon to tell with only 1 day but I'm optimistic. Glad you replied because I would have never thought of that.

1 Like

I'm glad that worked. I'm a little surprised as I knew it was a long shot (and little happy to know it's not just me :grinning:), but it was such a simple test I figured I'd at least mention my experience. I guess we'll know for sure after a couple days of testing. And if it proves out to be an 'on the hour' thing and it's not just me then maybe we can put it on Bruce's radar to look at when he has time.
Thanks for letting me know.

So far so good this morning as it's still working properly. Funny I have a hot water recirc pump I put on a Leviton 15 amp z-wave plug and half the time it won't shut off at the designated delay-off time. I now have changed that to a minute before the top of the hour and that too is working fine so far.

Great, maybe if more people have the same 'issue' then it'll be enough to put on Bruce's radar. Thanks for the feedback.

Hi @legends08, Just curious, it's been a few days how have your automations been running with this setup?

Hi Mark, glad you asked. I had it set up under the rule machine and it worked for a few mornings but one morning it didn't shut off. So I deleted the rule and went back to simple automation but this time I created 2 separate entries. One is to turn on every day at 0440 and that's it, end of that automation. Then I created another automation to have that switch turn off at 0559 every day. So far this way, it's been 100%. It has never failed to turn on at 0440 no matter what rule or automation I use. The hang up has always been to turn it off.
On the hot water recirc pump, I have 1 simple automation rule with the on and off in one entry and so far that has been 100% turning off now ever since I moved the off time from 1900 to 1859.
I've done several z wave repairs but not sure if that helped.