Sharptools "error sending command"

I posted this on the Sharptools forum, but thought I might also get some help/insight from here too =)



I’ve been slowly transferring my system over from AT/Smartthings to ST/Hubitat.

Generally going well, but I’ve hit a snag which seems to happen every now and then.

i.e. I click a tile, any tile, and sometimes get this:

The hub is fine, I can control the same switches etc from the main hubitat webUI. It’s definitely something to do with Sharptools.

Can you please assist? It’s killing the WAF. And I get the exact same error on both my phone, her phone, and my desktop.

Open live log and see what error comes up if any when you click on a tile.

Next time, I'll do that. This time I got sick and restarted the hub, which rectifies the issue.

My suspicion is it might be an issue communicating with the hub. I'd be interested to see if other things which use the Hubitat Cloud Relay are also experiencing an issue at the same time (eg. Alexa/Google Home/IFTTT).

Josh, I have a question somewhat related. I have a couple of tiles for a hue bulb. The bulbs were on but the tile doesn't show that they are (no glow). It could be when the bulbs turned on there was a communication problem between HE and Sharptools.

Those bulbs change color in the morning so I was expecting it to show on the dashboard but it didn't. Did Sharptools ignore the color change because it didn't 'see' the initial 'on'?

We should probably take this into a separate thread (or PM) so we're not hijacking the thread from @djh_wolf, but Hubitat's Hue Bridge Integration relies on polling.

Depending on how the devices are controlled, the hub has to poll the Hue Bridge periodically to get status updates. The first thing I would check is that the device details screen in Hubitat is reflecting the proper state. Using Hue Groups can accentuate this problem as it's harder for the hub to keep track of those state changes and it relies on the polling to get the status updates.

Yup, first time I seen it so I will start a thread on the board when it comes up again. We'll resume @djh_wolf's thread :slight_smile:

1 Like

Have you reserved an IP Address for your Hubitat Hub in your home router? Doing so really helps to keep the Hubitat Cloud endpoint server properly connected to your hub. This will then improve the reliability of any cloud service, like SharpTools, Alexa, Google Home, etc...

1 Like

Yeah, static ip addy. =/

1 Like

Had a lot of similar problems and finally replaced my cable providers router/wifi with a quality third party device and solved it. My modem is separate from the router/wifi.


Netgear dgnd4000 here. Had it for a good few years now. Provider's fibre modem.

1 Like