Set up issues

I have been struggling with my Hubitat and trying to read through the community posts as well - for hours and trying all the things I read. Where I am at:

  1. Hubitat powered up, gave me a blue light.

  2. Light has stayed blue.

  3. Hubitat provides me with a IP address and MAC

  4. Xfinity router shows its MAC as a connected device and lists its IP.

  5. wont find it until I enter the devices IP Address.

  6. Trying from several browsers, clicking Connect once it find it opens an error page.

  7. I have rebooted and reset from the diagnostics page.

  8. I tried turning off securities/firewalls just to see.

I am not a super advanced network/etc individual, some of the options that are described on the forums are above my skill level.

Tagging @bobbyD from Hubitat Support. Hopefully he'll be able to help get things sorted out.


Thank you!

1 Like

Sounds like the platform isn’t running - you would have a green light if it was. Are you able to get to the Diagnostic Tools at



You will need your MAC address from the bottom of the hub to log in to Diagnostic Tools

In the form:


From there, you should be able to reboot, download latest firmware version (currently, etc.

Oh, and welcome to the community, sorry you are having such trouble.


From the diagnostics tool it shows that it is running hub- I have rebooted, but do not have any option to download the current version you are seeing.

Also, I tried tried to reboot again, just for the sake of it, and I am getting a 401 error.

What version of Diagnostics Tool do you have? Current one is 1.0.92


This should update your diagnostics tool:


Perhaps I am assuming too much. What model Hubitat do you have?

When I enter this address with device IP i get a page that says didn’t send any data.

It doesn’t, and is silent, just triggers the update. Wait 5 or so minutes , go back to port 8081, see if it’s updated.

1 Like


Or, you may have to wait a day or two for Diag Tools to update. I recently got a spare C-7, out of box it had old firmware and old Diag Tools, and it auto updated Diag Tools after several days.

Ok. Patience seems like the next step. I appreciate your help

Well, actually, support (@bobbyD) should be the next step, but support has been largely MIA for the last few weeks, I suspect everyone is busy getting the next major release out.

What major release are you speaking of? I am new to all this and figuring it all out.

2.2.7, which has been in beta testing for awhile. I am not a beta tester, so I have no idea when the release will occur, except for a cryptic post from Bryan Copeland four days ago:

1 Like

:wink: Sooner than last message



To close the loop on this thread, support reached out and had me go through the following steps and it is now connected. The iOS app says the Hub is not responding, but it is at least connected to network and ready to go.

It sounds like the hub has not been properly formatted. When you get a chance, could you please try to factory reset the hub by following below steps, while you are on the local network:

If this doesn't work, please send us your hub's MAC address (there is a sticker on the hub) along with your hub's purchase order details (including the shipping address if the hub was purchased from one of our partners) so we can explore replacement options.