Serious issues [SOLVED]

Ha ok thanks. It looks like my WebCore app code is out of date so going to try updating that now.

OK I think I am good. It turns out that all three WebCore apps were updated on 12/8, which I think roughly aligns with when my issues started. While in safe mode I updated all three of these apps, then did the shut down/unplug/wait 30-45/plugged back in and now everything seems fine. Hopefully it stays this way. Will report back if any further issues. Thanks all for your help.

P.S. I inadvertently unplugged from the hub end but didn't break anthing! :rofl:

1 Like

I'm happy to report that everything is still working fine this morning, so it seems the issue was likely WebCore being out-of-date. Thanks again for everyone's help.

Does anyone know how I can keep Webcore up-to-date automatically, or at least be notified when there is an update?

You should update your thread title adding [SOLVED] so folks know that "Serious Issues" have been resolved :slight_smile:

2 Likes

Done, thanks.

If you haven't already, install Package Manager, and then run a Match. This should register webCore with the Package Manager; Package Manager runs an update check every 24 hours and will notify you if you have an app or driver that needs updating.

3 Likes

Thanks will check that out.

2 Likes

You should probably also make it clear that it wasn't actually a serious issue :stuck_out_tongue_winking_eye:

It seemed serious to me. Hub was completely unresponsive and inaccessible. Sure it’s a subjective statement, but if that’s not serious in terms of Hubitat issues, what is?

Reopening this as the issue has reappeared. Hub is completely inaccessible at its regular IP address but immediately accessible on port 8081.

@bobbyD any ideas please? This is getting frustrating.

A reboot brought it back to life momentarily but now frozen again.

That sounds like the database is corrupted. Have you tried Soft Reset?

Also, any errors in the Logs?

Thanks for the reply @bobbyD. I had previously tried soft reset and restore multiple times, before thinking I had fixed it yesterday with Webcore updates. I can try that again now.

Where do I access the Logs? I can only access the diagnostic tool and I don't see anything there.

I read through the whole thread, and, especially paid attention to your initial post. There is one thing that I don’t see that you have done (others may spot others).

You say that you did a soft reset and restored your most recent backup. However, I don’t see that you have done the sequence:

(1) Make a new backup and download it to your computer;
(2) Do a Soft Reset;
(3) Restore the downloaded backup.

Apparently, when you make and download a database backup, it prunes out garbage, so doing the above ends up with a database with no garbage.

I’m assuming that you don’t have a rogue app that is causing issues. For example, I don’t run WebCoRE, so I can’t speak to that.

Grasping at straws, I can think of one other remote possibility that I’ve never seen discussed in the forums, namely, that somehow the running platform firmware has become corrupted.

I suppose that one way to address this possibility would be, after doing the Soft Reset (from step (2)), would be to revert to an earlier version than 2.2.4.158 (I don’t know what prior versions your hub has in its list of previously-seen firmware, then restore the backed-up database (from step (1)), then do a firmware update to 2.2.4.158 (which is working fine on my C-7), which would download a new copy.

Now you cannot, but after a Soft Reset, when the hub is accessible, screen your logs for errors and warnings. The Soft Reset is only a band-aid to bring your hub to life. But if the same problems that brought the hub down in the first place, persist, it's a matter of time before it locks up again.

Thanks for the detailed reply. Trying this now.

Thanks, trying this now,

Soft reset brought it back just long enough for me to view the logs, but now it's frozen again.

I didn't see any red in the Logs but there were a couple of recent Warnings saying:

"Received cloud request for App 343 that does not exist, path: /ping from 54.83.153.160"

How do I know which App is App 343?

Edit: a search of the forums indicates this might be related to Hubconnect, which I do actively use. Checking to see if my Hubconnect software is up to date...

Click on App 343 on the error line, it will highlight the app in the list at top of logs listing.

1 Like

Good thinking, but as the error says:

That is an external source looking for an app that has been removed. The only way to stop that error is the remove the hub IP address from whatever the external source might be.

2 Likes

Might temporarily disconnecting the internet allow some time for more troubleshooting? Of if the issue goes away with the internet disconnected that is useful as well.

Download the Hubitat app