Sengled Color E11-N1EA woes

Good afternoon.

Hopefully someone can help me here. I bought a 3-pack of Sengled Color E11-N1EA bulbs. I see conflicting information here and am having issues. People say the Advanced Zigbee RGBW bulb driver, but it doesn't work for me.

Bulb #1

  • Tried “Advanced Zigbee RGBW Bulb” driver and it wasn't working right.
  • Used "Sengled Element Color Plus" driver and it connected well
  • Adopted into Google Home App but it's wonky and keeps reporting wrong state and power level.

Bulb #2

  • Settings above did not work. Bulb kept being removed from Google Home App
  • Used "Sengled Element Plus" driver and it pulled into Google Home, but colors are missing (only flavors of white)

Bulb #3

  • Tried the above options again
  • Used "Sengled Element Plus" driver and it pulled into Google Home, without colors, just to get it working

Any ideas?

Edit: this package did come with a Sengled hub as well, but I am obviously trying to avoid extra apps and hubs.

Since it's the driver Hubitat recommends, I would start with the "Sengled Element Color Plus" driver (likely how it paired). After you switch to a new driver, it's usually a good idea to run the "Configure" command (at the top of of the page), and if a Zigbee device doesn't seem to be reporting something correctly back to the hub, it's something you can try any time too. So, I'd try that too if you haven't already, then see if it behaves as expected.

Also, it would be good to clarify this problem:

Do you mean that Google thinks it's the wrong on/off state or level? If so, start by looking at the device in Hubitat first. On the device page for this bulb, look under "Current States" and see if things change there as expected when you turn on/off or dim the bulb. If that's wrong, Google will be wrong too, but at least you know where it's coming from. If it's just Google, there's probably less you can do about that issue, but at least you know.

Also, before you add a color-capable bulb to Google Home, make sure that all the color-related attributes are present and populated under "Current States." These would be hue, saturation, level, colorTemperature (assuming you have an RGBW device), and colorName, though I'm not sure how much that last one matters. People have reported problems adding devices if these are not all there.

Have you updated the firmware? I'm not sure but you might be able to update the firmware from HE if not then the Sengled Hub should do the trick. Just pair the bulb with the Sengled Hub (no need to exclude from HE) then do the update. Exclude from the Sengled hub then do a zigbee pairing in HE with the bulb in pairing mode.. it should pop up again where it was..

Thank you both.

I did the following and it seems to have fixed it:

  1. Removed each device from the Google Home app in HE and synced devices in Google, to make sure they were gone

  2. Gone to each device and hit the Update Firmware button. No idea if Updating the Firmware in HE did anything but I tried anyway.

  3. Changed the driver back to "Sengled Element Color Plus" (they had originally populated as Sengled Element Plus in response to bertabcd1234)

  4. Populated a random setColor and applied it

  5. Hit the Configure button

  6. Added each back into the Google Home app and did a sync device.

Everything seems to be working the way it should.

3 Likes

Download the Hubitat app