Sengled bulbs work through Group/Scene but not through devices

I installed 6 Singled color bulbs in one room some time ago. I added them to a group and also created some scenes and everything has been working fine since then. Today I wanted to add a new scene.

When I went to the individual devices to set the color etc. none of the bulbs responded. Yet the scenes that I had created previously are working fine.

I read a number of posts and tried changing the driver to generic zigged, from the Singled Element driver. No difference.

So why would they work from the scene but not individually from the devices? Any ideas? Thanks.

oddly, I mentioned a quirk this AM with a scene - and 2 of the devices were Sengled ... I wonder if there's a relationship?

Pretty sure @mrutenbeck is seeing this too. I don't have a solution, just reporting that I don't think any of you all are crazy for reporting the same thing. :smiley: We tried switching drivers, hitting "Configure," and re-pairing the bulbs. The latter worked for some, but I think a couple are still not responding, except via Groups...

I am running 2.2.9.146. I see that 2.3.0.111 is waiting to install. What versions are you running?

I’ve seen this happen in the past with Zigbee bulbs. Rejoining them fixed the issue in my case.

@bertabcd1234 is correct as I have seen that with a few of my Sengled bulbs too. Resetting the bulb and rejoining has fixed a couple of them but I have one that no matter how many times I reset and rejoin, I cannot control it from the device page. The device states update correctly though. So if the group turns the bulb on to a specific level/temp/color, the device state reflects it. I just tried this right now running version 2.3.0.112.

I am getting errors in the log as well:

dev:442021-11-24 05:01:27.351 pm errorjava.lang.NumberFormatException: For input string: "0A00" on line 235 (method off)

dev:442021-11-24 05:01:26.159 pm errorjava.lang.NumberFormatException: For input string: "0A00" on line 263 (method on)

Which driver?

@mike.maxwell I am using Sengled Element Color Plus

Those errors don't line up with the current driver code, which platform version are you running?, and have you tried the sengled legacy driver?

ok, I updated to 2.3.0.112.

Tested all 6 Singled bulbs through the device section and 2 work and 4 do not.

All work through the previously created groups and scenes.

I am using the Sengled Element Color Plus. I tried the Legacy version, and I also tried the Generic Zigbee RGB and RGBW drivers. None of them worked with these bulbs.

I am happy to try removing these bulbs and re-pairing if that will do the trick. But I don't want to do it just for testing as it will mean rebuilding my scenes - and if I cannot operate them from the devices then I cannot recreate my scenes.

I am not getting any errors in the logs. Any suggestions? Thanks.

This sounds like a mesh issue of some sort.
I'm presuming that you have zigbee group messaging enabled?, in which case zigbee uses multicast vs the unicast frames sent by the device details.

You can try toggling the power on the bulbs that aren't responding to the device commands, this should cause them to find a new path back to the hub.

I am also having an issue with 2 of my Sengled bulbs not responding to commands.
So, I created a group with the 2 bulbs, and in the same Simple Rule, I turned them both on individually, and then I turned them on with the group name.
No dice.
It says that they are on, but in reality they are not on.
Running the latest 2.3.0.110 on a C5.

Anyone have any suggestions?

No need to remove them, just reset the bulbs themselves by turning on and off rapidly 10 times (I think that’s how Sengled reset). Then rejoin them and the hub will put them right back without messing up any rules or scenes.

@mike.maxwell Ok, so I tried resetting one of the bulbs. It is 10 times on and off. I reset it, then added it back into Hubitat. Hubitat found it and recognized it as previously connected. So far so good. However, I still can't control it, and as I feared, the scene no longer works with it.

So either 4 out of my 6 bulbs have gone bad or something else has gone wonky?

I have a new C7 Hub that I am slowly migrating to. I tried adding it to that and it worked fine. I don't have any other Zigbee devices on this hub yet so no mesh. I could move all bulbs over there and use hub mesh with the groups and scenes unless someone can think of a way to get these bulbs working with the older hub? Thanks

What other types of zigbee devices are on the old hub?
The fact that the bulb works on one zigbee network (the new hub) and not the other (the older hub) points to a mesh issue on the old hub, this could be a misbehaving router or some other communication problem

I moved all of the bulbs to the C7 and all of them seem to be working so far.

All six bulbs are in the same room so it is a really weird mesh issue that would cause 4 of them to stop working.

Judging by the posts, it seems that there is more to this than a Mesh issue?

@mike.maxwell I am running a C7 with version 2.30.113. My issue is fixed now though. @bertabcd1234 switched the driver to "Device" and then ran the Delete All States. We then switched it back to Sengled Element Color Plus and it has since been working from the device page and the errors in the log are gone as well.

There is no difference zigbee wise between a c5 and a c7, same chipset, same code...

Download the Hubitat app