Sengled bulb - missing events/log entries

Hello - I have a Sengled bulb that is working correctly (can turn on/off from Hubitat app, rules and also Homebridge/Home app) but does not show any entry in the log or under events on the "device" page.

This one entry in the log showed up in the log while I was turning the bulb on/off multiple times from the Hubitat dashboard and Apple Home. There were no other entries since September (see below)

The bulb is in a clay lamp shade - could that be the issue?

It does work but "flaky" behavior bugs me (:man_shrugging:t4:), so was curious if anyone had an explanation or ideas.

If it's working fine (not sure what the other "flaky" behavior may be), then what could be happening is just the the bulb isn't reporting its state back as it changes, so the driver never sees anything to parse and eventually turn into an event. This could happen if you changed drivers or the device paired with the wrong driver and you manually changed it without hitting "Configure" afterwards, which for Zigbee devices generally, among other possibilities, tells the device what to send to the hub when. But even if you didn't do that, hitting "Configure" might help anyway. :slight_smile:

If that still doesn't help, then I'm not sure. Could you have Zigbee mesh issues? Do you have non-Sengled smart bulbs mixed with non-bulb Zigbee devices on the same Zigbee network? Could it be on the fringe of your network range? They clay shade probably can't help, but at least it's open on the bottom. If the bulb consistently responds to commands and a "Refresh" works to get the current state if that fails, then that seems less likely, but I suppose it's worth mentioning anyway.

A related issue is how to see events in Hubitat. The "Events" button/tab on the device page from your second screenshot is the authoritative source for that device. The "Logs" (live or past) may be helpful if you have "Enable descriptionText logging" turned on for that device--this is supposed to generate an "info" log any time the driver tells the platform to create an event--but it's just something the driver does to be nice, so "Events" would be the authoritative source. Yours seem to align, but just something to keep in mind.

The only other "flaky" thing is the event logging - I use node-red to log events to a database and that's how I noticed that this bulb was not publishing events (MakerAPI).

Nope - I moved to all Sengled bulbs a while back (based on your recommendation I think)

I'm hoping that I don't. This particular bulb is about 10 ft across the room (no walls etc.) from the Hub. I have 2 Zigbee repeaters for other bulbs that are further away (2 upstairs and 3 about 30 ft away). Everything else seems to log events and this particular bulb responds to on/off commands.

Unlikely, but could be - I will hit "Configure" again and see if anything changes.


Could the lampshade composition include lead or other minerals that are affecting the bulb's communication?

When you say "flaky behavior" are you just referring to the logs? Sounds like the bulb's functionality is not an issue, right?

Yep - flakiness is in reference to logs only.

It could be. I was trying to remember if I always had issues with this particular fixture (came from Wink with Cree bulbs to Hubitat with Cree and then switched out to all Sengled), but I'm not sure.

One thing I have noticed is that this bulb seems to have issues with correct "state" in the Hubitat app/device page. If I turn it on from the dashboard, it turns on almost immediately but the "tile" won't indicate that it is turned on. If I turn it off from Home app (via Homebridge), the device state in Hubitat device page is not correct. However, if I hit "refresh", it updates to the correct state.

What I may try is taking the bulb out and moving it to another location to test. At this point, it's just curiosity


Well - that seems to have fixed it! It’s now logging events for the past 3 days and also is publishing them through MakerAPI. Many thanks for your help :pray:t3:


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.