Schlage Connect Deadbolt - Zigbee Lock


#1

Purchased a Schlage Connect Deadbolt Zigbee Lock. I cannot get it passed the discovery page. This is as far as I get:

There are several threads with members stating they use Schlage Zigbee locks, hopefully I can get this one to work.


#2

do you have any bulbs connected to HE?, if so what brand...


#3

I only have Schlage Z-Wave Locks but in joining a lot of devices last weekend I ran into that on some Zigbee and Z-Wave devices sometimes it would sit there for 15 seconds before resolving the driver to use but other times I'd wait more than 5 minutes and it wouldn't ever continue so I then had to unjoin (Z-Wave) or reset the device then try again. I think I went through that process about 10 times for 1 device (at least 5 of those tries it was within a foot or two of the hub) before it worked. I've seen similar behavior with other hubs as well.


#4

I have no bulbs, the lock is my only Zigbee device. I have lots of GE/Jasco switches/dimmers/outlets and 2 Fibaro water sensors. These are all zwave plus. Since I posted I went to: settings, view Zigbee devices and found the device. I changed the type to: "Generic Zigbee Lock". Still no funtionality. I hit lock the lock does not lock.


#5

Tried removing and adding several times, looks like its working (at least I got the green light on the lock) report back soon


#6

Success!!! At least I am able to lock/unlock from HE. Will try the codes soon. Thanks for the help.


#7

I am considering the exact same lock in a new house build so I wanted to know how did you go in the end? All good?


#8

I have 4 of these. They work great. Much better than the z-wave verse that I had prior. Super reliable.


#9

Did you do anything special or just wait it out? HE finds it, but doesn't apply the right driver (or any driver really). Using the latest HE as of today.

edit: actually, the generic zigbee lock driver works.. ish. remote control works, but it seems to just lock itself automatically if you let it sit for a minute.

Edit2: I guess the auto lock is independent of the hub, it did it while not connected.