Scheduled cloud backup suddenly stopped running

Hey all,

I recently noticed that the daily cloud backups have stopped running on my C7 hub all of a sudden since a few days ago.

I confirmed that hub protect is active on this hub and rebooting the hub did not fix the issue. I tried running a cloud backup manually, which worked. I'm not sure why the daily scheduled backups become local only instead of cloud. I'm running

Any help would be appreciated!


Can you check if there is an app/driver creating a lot of scheduled tasks? They are listed under Logs - Scheduled Jobs. A handful of entries per app/driver is normal. A hundred isn't.


I have 8 tasks in there. Although I do have an app that creates like 20 one-off tasks in burst once a day. What's Hubitat's limit on scheduled tasks?

Huh the cloud backup ran yesterday but then broke again today morning. I haven't changed anything about the hub the past few days.

@gopher.ny I disabled the app that was creating a large number (~20) scheduled tasks and the cloud backup issue still persists intermittently. The hub currently has 7 tasks listed under scheduled tasks.
I've attached a screenshot of the backups below. Cloud backup ran on the 20th and the 22nd, but randomly did not run on the 21st.

Can you PM me your hub's id? I'll check engineering logs for more clues.
20 tasks shouldn't be a problem.