Scene's Missing from Activate Scene Listing in Rule Machine


I am trying to setup a rule to create and action of activating a scene. When I follow through the prompts of rule machine, I get to the point of selecting which scene I want to activate. The problem I am having is that it does not list the 2 scenes I have built - only one. Any thoughts on this? I have included screen shots below to show that I have 2 scenes and a screen shot to show that only one is showing up.

sorry trying to show screen shots but I keep getting an error that says I cant upload media - if anyone knows a way around that as well so I can show a screen print - that would be helpful too.


Welcome to the HE community!

Screen shot would be helpful. Maybe if you're new to the forum you have to somehow be approved to upload? Not sure.

In the mean time, does your scene show up in other apps like simple automation? Does it show up as a device? It should be listed as a "scene activator" device.

thanks brad

yes maybe its because i am new. i emailed support to find out why i can put in screen shots.

i checked the device listing and it present there just like my other scene as a scene activator

ok they have given me access. this should help

here is the dropdown of scenes to activate

Hmmm seems like it should work. Can you perhaps post screen shots of the two scenes? Or are there devices associated with "master bedroom fun" that are not suitable for a family forum :slight_smile: Also check your "devices" tab to see if both of those scenes made it to the list and properly show up as "scene activators."

lol, no nothing inappropriate.

Here is the device listing

Here is the snapshot of the scenes

Between the pot lamps in the living room and kitchen and the master bedroom fun I'm surprised you have time for home automation!

All kidding aside I can't see anything obviously wrong. What software version are you running? And is there by chance anything relevant in the logs?

1 Like

Did you try hitting "Done" in all the scenes, and going back and seeing if it shows up in Rule Machine afterwards?

thanks @brad5 for trying. Lol, love the jokes

@neonturbo - I havent been able to hit done yet on the rule as I cant actually select the scene to activate under the drop down menu for scene activation. - so not a problem getting ti to work, but rather a problem of being even able to setup the rule

Appreciate the input everyone. Thanks

Open Groups and Scenes, the parent app of the Scenes. Hit Done. Then, refresh the page in the rule, and they will be available.

nope, tried that but no luck. Even deleted the rule and tried to recreate from nothing - still doesnt show up

Show the App Status, application state for Groups and Scenes (gear icon).

Also show the portion of your Apps list that shows Groups and Scenes.

I also rebooted the Hub to see if something was hung up and didnt make a difference.

I also tried to clone the one scene that does show up to see if the new version of it would appear but it doesnt either.

Open each Scene and hit Done. Then look at that again. You can see there are no registeredScenes. That's where the info comes from. Show your Apps list for Groups and Scenes.

1 Like

I have gone into each of them and hit done - nothing seems to have changed. I have used those scenes multiple times from my dashboard so I know they work from there

AH, I went back into it again for a second time and hit done, and now they are showing in the drop down. What changed?

If I had already been using those scenes from my dashboard, I would have had to have already hit done before - so why is me doing that 2 more times making it work?