Rules hanging

my gues is that your mesh is not large enough or enough devices or extenders for 100% reliability. what does your mesh of devices look like.. are these zwave or zigbee etc.

99% are ZigBee. Most are lutron switches and dimmers. Others are ZigBee smart plugs. There is one z wave for lock. They are spread pretty evenly across the house and the hub is in the middle of the house on the main floor (there is also a basement and upstairs). Everything works completely reliably when I'm off turning it on and off from apps.

As far as devices, 42 lutron devices, 12 smart plug, and one z wave door lock.

Basic troubleshooting is as follows: We want to eliminate what it isn't. Whatever is left is where the problem lies. So first thing, is to look at the app logging. Turn on the logging in each rule that doesn't work right. Verify that the rule logs what it should. If it doesn't, let me know.

You will need to push these apps through their paces, perhaps even artificially. Don't wait for things that happen only once a day. Change how the app is triggered if need be -- temporarily -- to test and find out what happens. Start with a fresh Logs page, then force the app to run.

It isn't a reliability thing, it has to do with some error that hasn't been discovered yet. Hence, the need to troubleshoot the error. It could be our error, or it could be your error. We can't fix it until we discover what it is.


I may not be clear on the logging. It seems simple and straight forward, but I'm not seeing the info in the logs that I'm looking for. This is in the Simple Automation Rules app and I have the slider on for enable logging. Is there more to that? This rule doesn't show up in the log for today but it's enabled.

For Anything rule machine, I have these enabled for each rule so they'll log their actions.

I can only click about a few hours back on the "Show More" link at the bottom and the search doesn't always pull up the device or rule that I'm looking for. Clicking "Show More" usually takes it off the selection and takes me back to all for the log section. The device stats in the log section shows me the devices, but when I click on one, it takes me to the device page and doesn't show any king of log. And same with the App Stats section, it takes me to edit the rule I click on rather than a log of the stats for the app or rule.

Is there more to the logging that I'm not seeing? I have things reporting, I think.

This happened hours ago. So, it's going to show up in real time. Hence, my suggestion to force the rule to act, for testing purposes, temporarily. Put in a time about a minute in the future to turn on, and a minute after that to turn off. Then hit Done. See what happens in the logs. If that fails, it will tell us something. If that works, we'll have some confidence that the rule will work at different times than the temporary ones.

This rule is consistently not turning off. I have logging enabled, but can't find the log of the morning turn on or off. The log just isn't there. If I change the time, the log will appear and the rule works. In the morning, it turns on, but does not turn off. Today, the haloween lights were on all day.

There aren't a bunch of rules ending at 800am. Nothing that I know of is scheduled around the ending time so there shouldn't be any conflict.

When I change the times, it works. I ran it for two minutes, then for twenty. Both worked as scheduled.

I do have weird spammy something or another. I don't know if this is normal, but I saw this on a log and figured I'd see if it might have anything to do with it.

I'll do a new post with the other pics in it so this doesn't get too long.

I have a few devices that keep logging. It's weird. I can't get some things to log with it enabled, but devices will log on their own while they aren't active or used in a rule. Extra 1 is a smart plug that only mirrors the holiday lights. It is only used in one rule which is to turn on and off with the other holiday lighting. It was on all day because the rule never turned off. Apparently it logged every five minutes or so.

The playroom lamp is only used in one simple automation rule and turns on at sunset and off at 21:15 (and only when in home mode). It shouldn't be reporting anything or logging anything but keeps logging every five minutes.

I give up on this one. The rule isn't logging in the morning. Just turns on and never turns off. If I reset the times for a test, it works without issue and logs correctly. I've shifted the times in the morning just to make sure it wasn't something about turning off at that specific time. It works the same...turns on, doesn't log, and never turns off. The holiday stuff is running all day until I get home.

I moved it to Basic Rules and it seems to work now.

You didn't set the turn off time in that rule.