Rules-4.0 hangs in the middle of defining a new rule

I believe this is the first new rule I’ve tried to create since my Hubitat was updated with RM4. I’m trying to define a motion-triggered lighting rule that’s similar to some of my existing rules. The steps I took:

  1. In the Rule Machine, select “New Rule”
  2. Enter the rule name
  3. “Select Trigger Events”
  4. Select “Motion”
  5. Select the appropriate motion sensor
  6. “Update”
  7. “Done with this Trigger Event”
  8. “Done with Trigger Events”
  9. “Select Actions to Run”
  10. Select “Conditional Actions”
  11. Select “IF (conditions) THEN”
  12. Define “New Condition”
  13. Select “Mode”
  14. Select the modes when the rule should apply
  15. “Done with this Condition”
  16. “AND”
  17. “New Condition”
  18. Select “Switches”
  19. Select the appropriate set of lights
  20. “Update”
  21. Turn on “All of these?”
  22. Switch is “off”
  23. “Done with this condition”
  24. “AND”
  25. “New Condition”
  26. Select “Lock”
  27. Select the (virtual) light lock
  28. “Update”
  29. Lock state “unlocked”
  30. “Done with this condition”
  31. “Done with Conditional Action”
  32. Select “Activate Scenes”
  33. Select “Activate scenes per mode”
  34. Select the modes (same as used in the conditions)
  35. Click out of the mode selection list

At this point all fields on the form are locked, and there’s a spinner in the top right corner that keeps spinning indefinitely.

I’ve tried re-loading this page, and that just shows a box that reads “ Please wait, loading app Rule-4.0 ...” with a larger spinner underneath it, which also hangs indefinitely.

Forgot to mention: my Hubitat is “Currently running version:”. I’ll try updating that to later today, but I don’t see anything in the release notes which relates to this issue.

I'll step through your rule creation and see if I can replicate it.

Just went through all steps and no spinny forever. I'm on .145 just fyi.

Is there possibly an issue with the scene you selected? I'd check it again and make sure all the devices are valid in the scene and something didn't drop off or get deleted and still persists in the scene.

I haven’t got to the part where I can select any scenes yet.

Go to apps, add built-in app, groups and scenes and create a scene. You can then add that scene to an RM4 rule.

The scenes already exist (using Scene-1.2). But even after upgrading the Hubitat firmware, I still get stuck when trying to create the rule. :frowning:

Nothing on this page responds to clicking.

What browser are you using?

This might help: I opened up Chrome’s Developer Tools and found this error on the console.

Error occured at this point in the code:

I just went through all of your steps and had no problem with the page being locked.

Looks like it isn't picking up your scenes for whatever reason. Maybe try reinstalling your scenes app and recreate the scene just to make sure it isn't something in there hosing it up. Especially since two people have now went through your steps without issues.

Open Groups and Scenes and hit Done.

Then show the Application State from the App Status page of Groups and Scenes.

That looks correct. registeredScenes is what RM uses to fill the Scene selectors.

I don’t see how, but apparently that did the trick! I went to create the rule again and this time, after selecting the modes, it showed the available scenes. The Rule-4.0 rule has successfully been created.
Thank you. :slight_smile:

I will see if I can force that situation to occur (it shouldn't). Every time you create a Scene, it registers itself with the parent app. And every time you hit Done in the parent app, it refreshes that list. Both of those events republish the list. Maybe there's a hole somewhere on the RM side, expecting a list that isn't there.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.