Rule with delay problem

I have a Rule that turns on a device (Fan) 15 minutes after the HSM is armed. It has been working fine for the past couple weeks, then all of a sudden (no new updates), it just has stopped working. I see the logs show it fires off the trigger, even the Delay 15 minutes, but never ends up completing the Turn on device. Any thoughts what is going on? (I rebooted the Hub and still nothing):


It would help if you posted the logs for the rule, with Action logging enabled. Are you sure the Fan is working?

The fan does work, I can connect via a dashboard and turn it on. I checked the logs and they are empty for the rule right now, I'll see after it fires again tonight if I can post them after that. I do have all the logging I can enabled for the rule too.


I've tried that sometimes as well at night after it should have fired, and same thing.... I see in the logs that it starts the Delay, but the logs never indicate then either that it got turned on.

I just did that now, I'll see if it fires tonight again. The odd thing was this was all working fine with no changed and no software update and it just seems to have stopped. I'll also check the logs again tonight, but before logs all showed it work and the Delay 15 minutes fire, but then nothing else. (i would login via dashboard and turn it on manually).

There is no reason why this suggestion should change things but instead of putting in

Delay 0:15:00
On: Fan

Why not put the delay against the ON.

On: Fan   Delayed 0:15:00

Like I say, seems like the same but maybe it gets evaluated differently somehow. :man_shrugging:

I tried putting a delay on the action initially, but it never fired then. I changed to a Delay 15, then On. That worked fine until a couple nights ago when it started to not turn it on. Even the Events log for the "fan" unit only shows it when I manually turn it on from the dashboard.

Of course this time it did fire. I did see something odd in the logs, but it still did work.

I have a Radio Thermostat. That's the device, but not sure why that would interfere with a delay. The fan is a tasmota device on (not a thermostat). But that is device id C0A84224:0050, which is the only thing close to what it shows in the logs (but not the same).

I do have multiple rules that all trigger on the same Hsm status, one turns off a lot of lights and turns the heat down on the thermostat too. The second turns on the fan with a 15 minute delay.

Could they be interfering with each other? Only the second has a delay in it.