Rule to run after power restore? (lutron telnet to be initialized)

Hi guys,

when i have the power out, despite static ip, i need to 'initialize' the telnet connection by clicking into the lutron hub and 'initialize', then i see in the log the telnet starts working and then my pico work with my hue's through Hubitat. Otherwise they don't work.

So either i do something wrong, either i try to find a way as soon as the power is restored to initialize automatically...
is it possible to add it into the boot sequence?

thanks !!

Initialize runs on hub boot, it's possible maybe the hub is starting before the Lutron hub is getting on line?
I have two bridges connected to three different Hubitat Hubs, obviously I'm booting more frequently than others with platform testing, I've maybe had to initialize telnet 3 times in two years.
If this is a frequent issue (power that is), I would get some of your goods on a ups, your main switch, HE and Lutron.

1 Like

I have to do this manually as well. I have a rule that triggers this after the hub boots. I have to do this when there is a power failure that causes my router to reboot. My Netgear router takes FOREVER to boot.



Thanks so much! I was looking for that kind of trigger event but under time, not 'location'... Found it.

I found how to delay 3 min but i can't find how to run a command. run a custom action asks me for a type of device to select from and i picked a lot of types and never could find my lutron hub. i tried http requests and random stuff but i can't find it :confused:

thanks so much for helping me out. i am 95% there.

You want to pick the "actuator capability and that should show you the Lutron telnet device that you have to use the command of "initialize".

I tried in Rule 4.0. is it the wrong app maybe? can't find it :confused: :frowning:

Look for Custom Action.

I just plug my Lutron SmartBridge Pro, Hubitat hub, router, and cable modem all into the same UPS. It really prevents most issues caused by startup race conditions.

Here’s the details within RM4 to create the Custom Action

1 Like

Thanks so much! The ‘actuator’ was the thing i could not find....

Works perfect thanks so much everybody!!