Rule Machine Misfire

Hello everyone, things are going pretty well with my Hubitat.

One little quirk I have noticed is that sometimes Rule Machine will not fire. It is only in one instance, but it has been replicated a few times.

I have a contact sensor on the washroom door. When the door closes, AND the lights are less than 25%, turn on lights to 5%. When Door opens and lights are less than 25%, close lights.

The reson for the 25% thing ios so that I can test to see if someone has turned on the light switch (we have Caseta) so if someone turns on the light manually then the Rule won't turn anythign on or off.

A few times, I'Ve gone into the washroom, closed the doors (the lights were off every time) and the rule didn't fire. nothign came on. Tried opening the door and closing a few timers but nothing. Turned on the lights manually, then opened the door agauin, lights went off (as designed).

I checked the logs, and Hubitat saw the door open and close everytime, so I know its not my contact sensors,.

Any ideas?


1 Like

could you post these logs? Both the device and RM.. It would greatly help in identifying the issue..


Was going to say the same.
@philippompili the more information you can give us the better. Turn on the logs for the rule and screen shot them here and also show us the rule in question.
Personally I have had something similar recently, but when I dig into the events for me it was the device that missed a beet not RM but once we see what you see we can assist more.

1 Like

Ok, I turned on logs for the Rule and will revisit on the next misfire.



It's best to also turn on descriptive text logging in the driver aswell as it will show the device event at the same time (mine are usually turned all off, unless I'm digging into something).


Ok, I see what is happening here. Hubitat thinks the lights in the ensuite are at 100%, when in fact they are not.

Any advice on how to solve for Lutron Devices not reporting the right levels to Hubitat?

1 Like

Not sure exactly what your doing, but when you say they are not at 100% what do you mean? Are they in the OFF state but also show as 100% in the device page? If this is the case, then I would assume this to be correct (I don't have lutron) as all other devices work like this. The dimmer levels only change when you send them or the device reports it's change.

Do the lutron dimmers provide 2 way communication? Is when you send just a ON but the light levels were saying 100 but the light is at 50 does it update in the device page?

Borris, first let me apologise for the way I wrote that last post. it was a mess and not very easy to read.

The good news is that your comment solved it for me. I didn't realize, but 0% is not the same as OFF. Something can be at 100% and OFF. I added an OR statement and it fixed it.



Common error, philip - many of us found out the hard way that many dimmer devices contain both a dimmer and a switch.

Add a dimmer to a dashboard and look at the tile - even when it's OFF, you'll see the dimmer level represented.

1 Like

This is what I was getting at :slight_smile:

Perfect :grinning:

No need to apologise :+1: as long as you got it working!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.