Rule Machine errors since upgrading to 2.2.4

Seeing this error:

2020-11-25 02:18:42.271 pm errorjava.lang.NumberFormatException: For input string: ":1.1" on line 4929 (updated)

for one of my rules. Didn't get this prior to 2.2.4. Seems to break the rule. Recreated the rule from scratch and still get that error. I see the error whenever the rule triggers or I update it.

Looks like the error is caused by the trigger (Days of Week Schedule).

yes there was another thread about this and it is a known issue. they recommend for now using the chron option to schedule

I found that using "periodic schedule" seems to work a little better than "certain time" or "days of week schedule".

I don't know why, but several of my "certain time" triggers and "days of week" triggers simply didn't fire.

I tried different variations, but ultimately periodic with a 1 day repeat seems to work reliably.

That change appears to have gotten my time triggered rules working, and most of those errors gone, but I've certainly been seeing more Java errors in the 2.2.4 series, I don't know if there ARE more, or just whether we can SEE more, but im seeing a fair amount on rules that work....odd stuff.