Rule Machine Edits

Okay, having big fun with Hubitat but am having an issue with Rule Machine.

So if I create a rule to play a track on Sonos, works great.

I'm trying to change the track locations to a laptop that I'll be using in my other house.

If I create an entirely new rule, the path works fine.

If I edit an existing action in an existing rule and paste the new path, I get this weird result and the word "null" is included in the path.

So here is the new action with the new path pasted. "Dashboard" is the name of the laptop but I got the same result with the original laptop name. Notice I'm editing with the weird result already there because I clicked on it to save an image to upload AFTER saving the new edit.

When editing a brand new rule in RM, there is no path in parentheses in black as there is below.

And here is the result (highlighted in yellow) and notice there is the path containing the word "null" in parentheses:

I don't have an answer, but I have noticed similar issues when editing actions. When this happens, usually I'll just use "insert action" to make the necessary change and then delete the old line.

Edit: actually, maybe i do have an answer. It looks like your filename contains spaces, which are "encoded" as %20 in URLs. In Hubitat, the % sign is used to identify a link to a device name, value, or other variable (as seen in the last line of your rule) . I bet if you remove the spaces from your file names all will be resolved.


Great idea about the spaces! I will try that and post what happens. Thanks! :slight_smile:

Your solution worked! No more spaces in file names. Awesome. Thank you!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.