Rule Machine 5 - Nothing Triggers

I'm at a loss. I've rebuilt and rebuilt and rebuilt all my rules. Every last one of them runs correctly when I push "Run Actions". None of them trigger at the scheduled times. Very simple rules to turn on and off lights around sunrise / sunset. Please help?

Perhaps turn on logging and post a screenshot of the rules and what you see in the logs. Also, (1) which version of Rule Machine, and (2) what firmware version? There have been some issues with Sunrise/Sunset and some versions of firmware and Rule Machine.

1 Like

It's Version 1.0.3 (2/28/2022). All the Rules say Rule-5.1 beside them.

Hub firmware is

It doesn't work for specific time rules either. I'm perplexed. I spent 2 days moving all my rules from Legacy where they worked fine and now I have a "dumb home".

I turned on a couple logs and rebooted all the hubs. Will report back with logs later tonight.

I assume that means you recreated them from scratch, right?

Also would help if you posted the subscriptions for one of the rules that doesn’t trigger.

Here's one of the really simple rules that didn't trigger today. But when I "Run Actions" from that same screen, it works.

And yes, I recreated them all from scratch.

Ok, then logs will be instructive. Doesn’t get much simpler. Screenshots of subscriptions could provide info. I assume you pressed Done after editing, which registers the subscriptions.

In full disclosure, all of my certain time and Sunrise/Sunset rules are SAR (Simple Automation Rules) from almost 2 years back, never changed, always worked. My RM rules are all triggered on device events.


In the event that your subscriptions look correct but aren't executing when expected (or if you want to try this regardless), there was a case a while back where I think the same thing was happening, and it might have been database corruption. A soft reset and restore fixed the problem, as it can in these cases. (Do not reset any radios, and I'd suggest downloading a fresh local backup from Settings right before you do this rather than relying on one stored or created automatically by the hub.)


@user616 Can you check your settings>>hub details page and that your location (lat and long) is correct as well as your time zone?

1 Like

Looks like a hub reboot solved all the issues. Will monitor for a few days to ensure consistent routines. Thanks!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.