Rule Help - Persistent light state option with motion controller

Yes, it's not a supported device yet.

Try this: In the driver there is a method that looks like this:

private switchEvent(boolean on) {
    createEvent(name: "switch", value: on ? "on" : "off")

change it to this:

private switchEvent(boolean on) {
    createEvent(name: "switch", value: on ? "on" : "off", isStateChange: true)

We just bought one of these, and will look into doing a driver for it. We have some experience where Leviton dimmers pose difficulties. I have about 50 Leviton dimmers in my house, but they are older models and all work well with Generic Z-Wave Dimmer. But, there are still oddities about them. Your dimmer sends out a Z-Wave Hail command. This command is unique to the licensees of the now expired Lutron patent, of which Leviton was one. It's an instant reporting dimmer, but that driver of yours is suspect. If the fix above that I sent you doesn't solve the problem, you'll have to wait for us to get a driver working that does work right. I have no way remotely to tell exactly what is going wrong with this.

Yeah it looks like that did not work either. I did also try adding an override to another motion lighting app for my kitchen and it did not obey the override setting, so it must be something with the driver.

The Leviton's have been working good with HE, even with the custom driver. It was only until I tried using the override settings is where I started having issues.

With Alexa I also noticed that when I would issue a command to either turn one of the Leviton's on/off or change the level, a lot of the time she would either be delayed a lot and then say "ok" or say that it failed even though the light actually did go off/on.

Edited: Thanks for the help and I look forward to the new driver.

This is a sign that the driver is not sending out the events that Alexa expects to see, which lines up with Motion Lighting not seeing the events either. Driver issue.

I believe I'm seeing a very similar reaction from Hue Bulbs (connect via the Bridge). I send them a level change but the override flag next flips to true. I see the level change event happen in the logs (and the bulbs adjust) but the light still turn off when the pending schedule fires.

Its possible I have a misunderstanding of the rule so included it below.

This must be a physical event, as with manually adjusting a dimmer. Just sending a level event won't work. Or, you can use Alexa if you add the option to control with Alexa. Telling Alexa to set a level would also override.

Tried via Alexa with the same outcome, such as "Alexa set Office bathroom to 50%". When doing it the other way I'm using a Pico set to dim by 15% per press. The Pico is using Hubitat's Lutron Integration and not paired with the light directly.

It sounds like your saying this has to be a physical dimmer switch at which point this feature wouldn't be helpful for me. I'm Smart Bulbs throughout with couple few GE Z-wave (on/off) switches.

Thanks for the reply!

I did test with the one GE Z-Wave Plus Dimmer I have in the house and the override feature does work as intended. I also verified that "override" was true when manually changing level and would go back to false when turning off the light.

Also I can clearly see the "digital" and "physical" events in the log.

So this pretty much confirms that it was a driver issue.

The motion lighting apps I set do work as intended as long as I do not turn on the override function. I did notice however the two code edits that you had me try before did seem to break my motion lighting apps. I reverted back those edits and removed/re-installed the apps and all is well again.

If you need someone to test the Leviton Dimmer drivers I have no problem helping out. Thanks.

Sounds good, thanks.

And that dimmer is directly supported in the next release as well...

1 Like

Awesome! You guys rock.

How much longer until next release. I get giddy looking forward to these great updates.

It's planned for November. :upside_down_face:


Thanks for adding the dimmer in the new release. But I seem to have found an issue, this even happens with the GE dimmer I have, If I turn the light on/off from the switch the status updates correctly in HE. But if I turn the light on from the switch and then off from HE, the status in HE still says "on" even though the light actually did turn off. Its not until I actually hit the bottom paddle button that HE updates its status to "off."

Edit: I also noticed with the Leviton Dimmers when I turn them on/off from HE that there is nothing in the logs and no events.

Here is the log when I manually turn on the light from the dimmer.

dev:7092018-10-03 22:45:26.588 info Living Room Lights is off [digital]
dev:7092018-10-03 22:45:26.577 debug dimmerEvents value:0, type:digital, bin:-1
dev:7092018-10-03 22:45:26.529 info BasicReport value: 0
dev:7092018-10-03 22:45:26.528 debug parse description: zw device: 22, command: 2003, payload: 00 
dev:7092018-10-03 22:45:26.150 debug skip: Hail()
dev:7092018-10-03 22:45:26.145 debug parse description: zw device: 22, command: 8201, payload: 
dev:7092018-10-03 22:45:18.464 info Living Room Lights was turned off [digital]
dev:7092018-10-03 22:45:18.454 debug dimmerEvents value:35, type:digital, bin:-10
dev:7092018-10-03 22:45:18.448 info BasicReport value: 35
dev:7092018-10-03 22:45:18.445 debug parse description: zw device: 22, command: 2003, payload: 23 
dev:7092018-10-03 22:45:18.056 debug skip: Hail()
dev:7092018-10-03 22:45:18.049 debug parse description: zw device: 22, command: 8201, payload: 
dev:7092018-10-03 22:44:23.517 info Living Room Lights was set to flash with a rate of 750 milliseconds

These events are from manually turning on the switch. I figured it should show "physical" but it is showing digital.

What is the exact model of the dimmer you have?, and what driver is it currently using?
The generic zwave smart dimmer driver was specifically updated to accommodate the Leviton DZ6HD-1BZ dimmer.

That is the dimmer I have.

Edit: I forgot to mention after I changed the driver to the 'generic zwave smart dimmer" I also used the "configure button" just to be sure it updated properly, but this did not help.

Well, maybe its a different firmware version, i have two of these nib, i tested with the newer one, no idea how old the other one is.
When I have time I'll pair up the two of them and see of there's any difference.

I can check versions if you want if its possible, just not sure were to see the version? I have a bunch of these dimmers that were purchased over the course of 1.5 years including one as recently as last month.

16 posts were split to a new topic: Support of OTA firmware updates for Z-Wave / Z-Wave Plus devices

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.