Rule failing, I know why but don't know what to do about it

Below is a rule that is supposed to regulate the humidity in the master bedroom. The bottom portion is the same rule that I use with the living room humidifier and it works great. The issue is that the master bedroom rule has times and modes set in the required elements and the living room rule doesn't. I found that if the humidity goes low at say 7:45AM it will turn on the humidifier but after 8:00AM the rule will not run to turn off the humidifier because of the required elements. Anybody have an suggestions to fix this? Thanks

For it to turn off after the required expression is false, you can do the following (which will also simplify the rule a bit…):

Humidity >= 50

On: MBE Outlet
Wait for Humidity >50
Off: MBE Outlet

1 Like

I will give that a try. Thanks.

1 Like

Possibly a typo? Pretty sure that the "Wait for" step should be "<" as opposed to ">". As written right now, the wait will be satisfied instantly.

Also, I would wait for it to get a little lower than 50 (Say 45 or even 40). The reason being that you may wind up causing VERY short cycles on the dehumidifier.


Bingo...that certainly looks must be like a typo.


@davidcwright59 does refer to the device as a humidifier, and the conditions in the original rule also point to this, so would assume he is wanting to push moisture into the air, i.e. raise the humidity, so >50 as the condition would make sense. If the humidifier reference was a typo, then yes, waiting for it to drop would be the right condition.

His original rule was to turn off at >=55 and turn on at <=50. So, yes, probably got my terms backwards.

Regardless, you can't have trigger at **>=**50 and wait for at **>**50. That means the trigger will satisfy the wait for and basically cancel itself out. One of those arrows has to point the other way or the wait for needs to be a larger number. So, there is a typo in there somewhere.


Ah, yes, we are both correct :slight_smile:


Yes, you guys are both correct. I figured there was a slight mix up on the >=50, I have a dehumidifier in the basement and humidifiers upstairs and I use RM to control both. Below is the rule that I ended up using. It functions perfectly.


Yes, I initially had <= as the trigger in my example. I updated it to >= but forgot to also update the >50 in the actions. Good catch!

Glad to hear that you were able to set up in a way that works!

I appreciate all your help.

1 Like