Rule 5 - No longer showing PAUSED Rules in Apps Display

In Rules 4.x any Rule that was Paused was marked with with a RED PAUSED notice.

The only way to detect a Paused Rule in Rules 5 is by checking each one at a time.


I was seeing similar inconsistencies with this earlier this week - I had to swap out my garage door opener, so I paused several (RM5) rules related to it during that work...

On the Apps page, a couple rules showed as "Paused", but a couple didn't (though they all showed as paused in each rule's own details page). It was strange - tried a bunch of page refreshes, unpause/pause resets, etc but no joy.

Definitely not a huge deal for me since I rarely pause rules, but still an oddity.

Actually some Rules showed Paused some others do not.

I love a good inconsistency :slight_smile:

I have about 50 'Legacy' Rules I was trying to re-write into Rule 5,

I got as far as 6 of them and ran into several issues of Rule Breaking on creation, a more convoluted way to work with variables, and inconsistent labelling of Paused or not, and getting stuck in a brand new Rule I was re-creating leaving me in cut de sac.

So have now stopped further work on Rule 5, and moving the Rules I had migrated back to Legacy until Rule 5 is stable.

Will suspend all updates in case an update wipes Rules 4.x out, and check them very closely indeed before implementing, I cannot afford to lose all these Rules I have created.

May have to get another HE Hub so I can properly test new releases when they come out.

I have a workaround for the no PAUSED display issue

Append the beginning of the Rule Name ******PAUSED ******* when you Pause it so you can quickly tell if it is Paused or not.

Works a TREAT

1 Like

Rule 5.0 IS stable. The display of Paused is at most a cosmetic issue. There are circumstances in which the display may not be updated, and these will be resolved in the next release.

Nothing will ever wipe out existing Rule 4,x rules. Our updates do not invalidate existing rules, even as we move on to new version of Rule.

You could be helpful by showing the circumstances in which the Rule Paused text is not appearing when you expect it to.

2 Likes

Ok

Can we agree to disagree on ‘stable’ in the common pursuit of ‘better’?

Regarding Paused not showing in App List for RM5 Rules.

I have tested on the 6 Rules I created, I opened the Rule pressed Paused, the Red Paused appears at the top of the Rule.
Pressed (from memory) Done

I would expect the word Paused in red appended to end of the Rule name.

All 6 rules Paused, none currently showing as Paused in App List, all checked and confirmed showing as Paused.

I did have one, just one, that did show as Paused but did not remain for long until it was gone.

The other issues with a Stuck Dead End Rule that lost the button to complete it, the issue of the Rule that was not functioning that had developed a Broken Action, combined with ‘cosmetic’ issue of not showing Paused when Paused, and the additional complexity in triggering off a variable, meant a 33% failure in Rule creation, more complex (more actions to complete same task in RM4, and not being easily detect a Paused state, I believe, demonstrates opportunities for improvement.

The benefits of RM5 I believe will warrant the interim maturity phase, so remain excited for the future.

Great to know the RM4 will remain supported for foreseeable future, I see legacy and I expect redundancy, then expulsion. :slight_smile:

Please explain in more detail. The red Paused appeared at the top of the page, and then you hit Done, You didn't see Paused on the rule name in the Apps list, right? Did you try refreshing that page? Was it still on the top of the app page when you opened the app again?

It’s late here

See the images at the beginning of the thread.

I have not tried refreshing screen because I have been moving between, settings, apps, devices, would expect it to update then?

Just opened Apps on this iPad, and 4 of the 6 paused rules are showing as paused.

Going from some other page to Apps page is the equivalent of refreshing the page (not a dynamic page). If you open one of those two apps that do not show Paused, do they still say Paused at the top of their app page?

Yes

Just so you know, the way this works is that the Rule actually changes its own name to include the red text '(Paused)'. The Rule does not cause the display of its name in white text in the black border of the top of the page -- the platform does that. If the name of the Rule with the Paused in red does not show up in the Apps list page, but it does show up in the Rule itself, this is most likely a browser cache issue, where the prior page, without (Paused) as part of the name, is being displayed. Usually a page refresh will cure this (or clear your cache -- with Chrome I've never seen this happen). This is also not something that the code of the Rule does, but again the platform. (So don't go blaming the "stability" of Rule 5.0.)

You can always verify the actual state of paused by examining the App Status page. In the Application State it will show this:

The implementation of Paused has not really changed since it was introduced perhaps two years ago. The cosmetic issue I alluded to before has to do with the interplay between (Predicate False) in red, (Repeating) in amber, and (Paused) in red -- each of which may occur. But, you didn't report that (Predicate False) was being displayed instead of (Paused), and I don't see how this could happen as Predicate Condition checking is also paused when the rule is Paused.

2 Likes

just a thought, perhaps the UI could be changed so that there is a separate column for pause/predicate false that just indicated the state of the rule rather than changing the actual name of the rule?

Yeah, we've talked about that. For now, this is how it's done. Apps page to be revisited at some point...

4 Likes