Room Lighting Incorrectly Activating when Illuminance CHANGES instead of Falls Below

I have noticed this happening on a few of my room lighting apps. I have the below room lighting app set up to activate when illuminance “falls below” 12 lux; however, any time that the illuminance changes (even increasing) below the 12 lux “don’t activate above” threshold, the room lights are activating. See logs showing the illuminance was at then and then increased to 6, which caused the room lights to activate.

Is anyone else having this issue? @support, could this possibly be a bug? Thanks!

No, this is as designed. See: Room Lighting | Hubitat Documentation

NOTE: Illuminance-based means to Activate will cause Activation any time a matching lux reading is reported, not just the first time this threshold is crossed [ ... ]

I believe there was some discussion about changes to the phrasing in the drop-down to prevent this confusion (maybe "reports less than"?), but I think this is still the original wording.

Thanks, I missed this. Agree that changing the wording would be good, or ideally this should be adjusted to only trigger when dropping below the specified threshold as I think this is what users really want when this is specified.

To work around this, I’ll put in place a restriction to not activate during night mode or during the time that the lux is increasing from 0 to the threshold (e.g., sunrise -120 to sunrise +120).

The wording in the room lighting app is “illuminance falls” and “Illuminance Sensors that fall” as shown below, along with “Lux level to turn on at.” So definitely bad wording. IMO should be “changes” instead of “falls” and “Lux level below which a change activates the lights.”

For now I simply removed this trigger and am hoping that I’ll be moving enough to trigger motion after the lux falls below 12. Maybe I’ll set a reminder to do some desk aerobics as evening approaches.