Room Lighting Automation logs Already Activated when switching between Multiple Modes

I am testing my new light automation using the new Room Lighting app. I have multiple modes configured...basically turn on lights to 100% at dusk [evening mode] then turn one off and dim others to 10% at 10:30pm [night mode].

Evening mode is triggered fine and turns on the lights as expected. But when night mode is triggered, the actions are not carried out and the log reads "Already Activated". This appears to be an issue with the app. But willing to accept that I might not be understanding how "Use per-Mode settings" is supposed to work in this new app. Below is my configuration of the Room Lighting app and log entries. Thoughts/Experiences?


image

There is an option to still activate if already turned on. I'd need to look it up to provide the exact setting, but see what you can find.

1 Like

2 Likes

What about the option "Adjust lights on mode changes". I read the Room Lighting documentation, but that description is a bit vague about what it does. Do you have some insight?

Thanks for your suggestion. I see "Activate even if already partially Activated". I made the change, let's see how it does tomorrow.

1 Like

If it's like the Motion Lighting App, which I expect it will be, it means if the room lighting is "activated" at the time when the mode changes, and you have defined per mode settings, the lights will automatically adjust when the mode changes. For example, I have a Day mode, where I turn the lights on quite bright and a whiter shade. I also have an Evening mode where the lights come on slightly dimmer and a softer yellow shade. If I have triggered the lights in the room and the mode changes from Day to Evening I would expect the lights to go from the Day scene to the Evening scene.

1 Like

Thanks for that explanation and example, that's helpful. Sounds like I should choose that option too.

1 Like

Thanks all for your help. That indeed was the setting I was missing and my lighting behaves as I expect it to now with it enabled.

2 Likes

Glad it worked and thanks for reporting back!

That's often missed in posts like these. Then somebody comes along a year from now with the same problem wondering if the suggested fix actually worked.

1 Like

Download the Hubitat app