Room Lighting - activation happens despite restriction

I have a room lighting setup with a restriction set not to activate when mode is 'Away'. The restriction fails and the lights activate by time period anyway. I can't seem to figure out what is wrong in my setup :

A debug log appears mentioning "Activation prevented by mode Away" but as the previous log entries attest (and the individual device status confirms), activation has already happened... Interestingly, "Activation event: time" appears twice in that log sequence.

Time periods are set up this way:

Any ideas?

1 Like

I will look into this...

Thank you @bravenel . Some additional info.

I removed the "Adjust lights on Time Period changes" option and just tested that the restriction works now. TBH I don't even know why I had that option checked, I think it's leftovers from when I didn't really understand the "activation" concept.

I went back and checked the "Adjust lights on Time Period changes" again, and sure enough:

Side note : to run these additional tests, I was tweaking the offset on the Evening time period and noticed that when I did that, the lights were activated (back to the Day period settings), in spite of mode being Away.

1 Like

So adjust on Time Period changes is not following the Conditions to Limit Activation. However, it's not at all clear that it should, as the lights are already activated.

Except they were not activated, they were off.

In all three sequences above, the initial conditions are the same : time period is 'Day', mode is 'Away' and the lights are turned off. When the time for period 'Evening' is reached, the restriction is only ignored if the option to "Adjust lights on Time Period changes" is checked.

I am not sure what this "Adjust lights on Time Period changes" option is supposed to do - is it for dimmers or colored bulbs that might be "activated" (already turned on) but perhaps not currently set at the same level/color as specified in the app? In my case, I only have simple switches so if my understanding is correct, it makes sense that I can do without that option.

Let me know if I can run further tests to help investigate.

I have replicated your RL setup, and it doesn't fail for me. My logs are like this:

And the setup is this:

If the lights are already on when the time period changes, it will adjust them to the new time period settings. But it's pointless with the Means to Activate of 'Activate at Time Periods Start', since it is redundant.

Baffling. I don't know what to tell you. I just repeated the experiment now, same result.

So I went ahead and recreated a new instance from scratch with the exact same options (including the adjust option) and... this new instance works :man_shrugging:

Anyway, thanks for your help.

Something got ganked up (technical term)...

Download the Hubitat app