RM: Time Of Day. Between Times does not save


#1

I have just tried to define a new rule.
When I select 'Time Of Day' and then 'Between Two Times', if I select a specific time then the time input does not save. If I select either sunset or sunrise then that is saved OK. If I leave it blank it automatically inputs the current time.
I have tried in Chrome, (normal and incognito) and Firefox.
Same result.

EDIT: Same thing when using Chrome on my mobile.


#2

29%20AM

Can't duplicate

OR

I am misunderstanding your description.


#3

No you are not misunderstanding my query.
If I put in a specific time, it does not save.
Let me try again only having the one condition as you have.


#4

There is a bug in entering time in 24 hour format, which is probably what you're doing. Temporarily switch to 12 hour, setup the rule, then switch back. But has been fixed, in next release.


#5

Ah ha. Spot on.
I am using a 24hr clock.
Thanks. Will give it a go.
EDIT: Thats it. Thanks.


#6

FYI
I had the same issue trying to change times in a Simple Lighting rule


#7

Glad I stumbled on this thread. I was having the same problem with automating my Christmas Lights turn-on/off. Since sunrise/sunset worked, I just said "sunset + 360 minutes" for the turn-off time.

I'll redo my rules now (or leave them... but at least I know how to fix).


#8

The 24 hour time input has been fixed, but I just noticed that it displays it in RM (and probably other apps) in 12 hour format. That will get fixed.