RM Set Color issue after 2.3.9 update

On 2.3.9 (currently on .150 on a C4) when an RM set color command executes and the existing bulb color is not the requested color, the color changes but the level does not change. However on subsequent exeutions the level is correct. This worked on 2.3.8 and prior versions, although the bulb would first turn on with the the existing color and level before quickly changing to the requested color and level.
Bulb: Sengled Element Color Plus
Driver: Advanced Zigbee RGB Bulb

Any suggestions or workarounds appreciated.

I don't believe the "Advanced..." drivers were meant to work with any Sengled devices, at least not most of them. Does it work if you revert to the Generic or Sengled-specific drivers?

Thank you for that suggestion. Changed driver to the Sengled Element Color Plus and did a Configure, but the bulb no longer turned on after issuing the Set Color command. Added an On command after the Set Color and things seem to be working.

It should turn on. Do you have any of the "pre-staging" options enabled? That will make it need a separate "On" command (and is not something I'd recommend unless you know all the implications of enabling it).

1 Like

Whatever was set for the driver is what I used, and yes Prestaging is set On explaining the need for the On command.

This behavior would seem to explain something I'm seeing on a Gledopto clone device I haven't had a chance to troubleshoot yet. It's also using the advance Zigbee RGBW bulb driver. This device has worked reliably "for years" so this may indicate it might be related to changes recently made by Mike Maxwell to this driver to fix something that was broken with a prior change.

1 Like